summaryrefslogtreecommitdiff
path: root/package/python-serial
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-01-11 21:45:55 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-01-25 08:59:58 +0100
commit0eafafbe3dcff1362ee7f0617af6b75e22cd5014 (patch)
tree50366121651c541ef61a739ed25343e4bae38b7a /package/python-serial
parentb0c86bcc57b1bd714dc0d1cc719ffdfd6f0663dd (diff)
python-serial: new package
python-serial is a Python library to access serial ports. This package has originally been introduced to test that third-party pure Python modules (that do not use C extensions) build properly against the Buildroot Python infrastructure. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-serial')
-rw-r--r--package/python-serial/Config.in8
-rw-r--r--package/python-serial/python-serial.mk21
2 files changed, 29 insertions, 0 deletions
diff --git a/package/python-serial/Config.in b/package/python-serial/Config.in
new file mode 100644
index 000000000..ea090bda5
--- /dev/null
+++ b/package/python-serial/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_SERIAL
+ bool "python-serial"
+ depends on BR2_PACKAGE_PYTHON
+ help
+ python-serial is a Python library to access serial ports.
+
+ http://pyserial.sf.net
+
diff --git a/package/python-serial/python-serial.mk b/package/python-serial/python-serial.mk
new file mode 100644
index 000000000..048930bae
--- /dev/null
+++ b/package/python-serial/python-serial.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# python-serial
+#
+#############################################################
+
+PYTHON_SERIAL_VERSION = 2.5
+PYTHON_SERIAL_SOURCE = pyserial-$(PYTHON_SERIAL_VERSION).tar.gz
+PYTHON_SERIAL_SITE = http://pypi.python.org/packages/source/p/pyserial/
+
+PYTHON_SERIAL_DEPENDENCIES = python
+
+define PYTHON_SERIAL_BUILD_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build)
+endef
+
+define PYTHON_SERIAL_INSTALL_TARGET_CMDS
+ (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
+endef
+
+$(eval $(call GENTARGETS,package,python-serial))