summaryrefslogtreecommitdiff
path: root/package/qt/Config.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-03-20 15:19:12 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-03-28 00:02:46 +0200
commit421cda1fd078f5fa7902f05bd1d2021fd101d9ea (patch)
treebd0c6c51f7a59cd74a1dc4570479973df9b4cd5c /package/qt/Config.in
parent4c5ca3d27d510146f2e7c4a7c36c1c1d632909e9 (diff)
qt: convert to the GENTARGETS infrastructure
In addition to converting the qt package to the GENTARGETS infrastructure, this commit also does the following (related) things in the Qt package: * Create a BR2_PACKAGE_QT_CONFIG_FILE option, which can be used to pass a custom Qt configuration file, such as the ones found in src/corelib/global/qconfig-*.h. This used to be possible, but required changing qt.mk directly, which isn't really how we configure things in Buildroot. * Remove the BR2_PACKAGE_QT_EMB_PLATFORM option, the embedded platform name is now computed directly in qt.mk. * The QT_CONFIGURE variable, which hosted all ./configure options, has been renamed to QT_CONFIGURE_OPTS, for consistency with what we do in the AUTOTARGETS infrastructure. * The QT_DEP_LIBS variable has been renamed to QT_DEPENDENCIES, so that dependencies are properly handled by the GENTARGETS infrastructures. * The QT_QMAKE_SET macro (used to adjust the path/flags of the compiler/linker) has been extended with an additional argument, which allows to pass the source directory of Qt. * All the installation procedure has been rewritten to fit within the GENTARGETS mechanism. [Peter: fixed minor issues pointed out by Will] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Luca Ceresoli <luca@lucaceresoli.net> Acked-by: Will Wagner <willw@carallon.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt/Config.in')
-rw-r--r--package/qt/Config.in33
1 files changed, 13 insertions, 20 deletions
diff --git a/package/qt/Config.in b/package/qt/Config.in
index 2eb05e4ec..b223772cf 100644
--- a/package/qt/Config.in
+++ b/package/qt/Config.in
@@ -55,6 +55,19 @@ config BR2_PACKAGE_QT_LICENSE_APPROVED
LGPL v2.1: http://doc.trolltech.com/4.5/lgpl.html
GPL v3.0: http://doc.trolltech.com/4.5/gpl.html
+config BR2_PACKAGE_QT_CONFIG_FILE
+ string "Config file"
+ help
+ Configure options allow to set which modules are being
+ compiled or not in Qt, but Qt also provide a more
+ fine-grained mechanism to configure which features should be
+ enabled or disabled, through a header file. Examples of such
+ header files can be found in src/corelib/global/qconfig-*.h
+ in the Qt sources.
+
+ This option allows to set the path of such a configuration
+ file, which Buildroot will give to Qt at compile time.
+
config BR2_PACKAGE_QT_QT3SUPPORT
bool "Compatibility with Qt3"
depends on BR2_PACKAGE_QT_GUI_MODULE
@@ -240,26 +253,6 @@ config BR2_PACKAGE_QT_SYSTEMZLIB
Use the shared zlib from the system.
endchoice
-config BR2_PACKAGE_QT_EMB_PLATFORM
- string "The embedded platform we are making Qt for"
- default "arm" if BR2_arm
- default "arm" if BR2_armeb
- default "avr32" if BR2_avr32
- default "x86" if BR2_i386
- default "x86_64" if BR2_x86_64
- default "mips" if BR2_mips
- default "mips" if BR2_mipsel
- default "powerpc" if BR2_powerpc
-# Not that I really believe these will work..
- default "generic" if BR2_alpha
- default "generic" if BR2_chris
- default "generic" if BR2_m68k
- default "generic" if BR2_sh
- default "generic" if BR2_sh64
- default "generic" if BR2_sparc
- help
- The target platform.
-
source "package/qt/Config.sql.in"
if BR2_PACKAGE_QT_GUI_MODULE
source "package/qt/Config.gfx.in"