summaryrefslogtreecommitdiff
path: root/package/qt/qt.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-16 23:55:30 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-16 23:55:30 +0200
commit470e9deec1a740d3cf87fdf7598524560632ce0b (patch)
tree9ae44d3f6ae2c31434e4a3fa5abc2bdfe54f21ea /package/qt/qt.mk
parentb922151c25a5b0a2e5555700e0a809779809e436 (diff)
qt: fix mysql dependency and disable unavailable sql drivers
We don't have the needed dependencies in BR for most of the SQL drivers, so mark those options as broken. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt/qt.mk')
-rw-r--r--package/qt/qt.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index dd43ae02b..864e79bb6 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -273,7 +273,9 @@ ifeq ($(BR2_PACKAGE_QT_IBASE),y)
QT_CONFIGURE+= -qt-sql-ibase
endif
ifeq ($(BR2_PACKAGE_QT_MYSQL),y)
-QT_CONFIGURE+= -qt-sql-mysql
+QT_CONFIGURE+= -qt-sql-mysql -I $(STAGING_DIR)/usr/include/mysql -L $(STAGING_DIR)/usr/lib/mysql
+
+QT_DEP_LIBS+=mysql_client
endif
ifeq ($(BR2_PACKAGE_QT_ODBC),y)
QT_CONFIGURE+= -qt-sql-odbc