summaryrefslogtreecommitdiff
path: root/package/qt
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-16 23:55:30 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-16 23:55:30 +0200
commit470e9deec1a740d3cf87fdf7598524560632ce0b (patch)
tree9ae44d3f6ae2c31434e4a3fa5abc2bdfe54f21ea /package/qt
parentb922151c25a5b0a2e5555700e0a809779809e436 (diff)
qt: fix mysql dependency and disable unavailable sql drivers
We don't have the needed dependencies in BR for most of the SQL drivers, so mark those options as broken. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt')
-rw-r--r--package/qt/Config.sql.in7
-rw-r--r--package/qt/qt.mk4
2 files changed, 10 insertions, 1 deletions
diff --git a/package/qt/Config.sql.in b/package/qt/Config.sql.in
index 2ce8d7964..b982fdb4d 100644
--- a/package/qt/Config.sql.in
+++ b/package/qt/Config.sql.in
@@ -6,24 +6,30 @@ menuconfig BR2_PACKAGE_QT_SQL_MODULE
if BR2_PACKAGE_QT_SQL_MODULE
config BR2_PACKAGE_QT_MYSQL
bool "MySQL Driver"
+ select BR2_PACKAGE_MYSQL_CLIENT
+ select BR2_PACKAGE_NCURSES
+ select BR2_PACKAGE_READLINE
help
Build MySQL driver
If unsure, say n.
config BR2_PACKAGE_QT_IBASE
bool "iBase Driver"
+ depends on BROKEN # libfbclient not in BR
help
Build iBase driver
If unsure, say n.
config BR2_PACKAGE_QT_ODBC
bool "ODBC Driver"
+ depends on BROKEN # libodbc not in BR
help
Build ODBC driver
If unsure, say n.
config BR2_PACKAGE_QT_PSQL
bool "PostgreSQL Driver"
+ depends on BROKEN # libpgsql not in BR
help
Build PostgreSQL driver
If unsure, say n.
@@ -36,6 +42,7 @@ config BR2_PACKAGE_QT_SQLITE
config BR2_PACKAGE_QT_SQLITE2
bool "SQLite 2 Driver"
+ depends on BROKEN # sqlite2 not in BR
help
Build SQLite 2 driver
If unsure, say n.
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index dd43ae02b..864e79bb6 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -273,7 +273,9 @@ ifeq ($(BR2_PACKAGE_QT_IBASE),y)
QT_CONFIGURE+= -qt-sql-ibase
endif
ifeq ($(BR2_PACKAGE_QT_MYSQL),y)
-QT_CONFIGURE+= -qt-sql-mysql
+QT_CONFIGURE+= -qt-sql-mysql -I $(STAGING_DIR)/usr/include/mysql -L $(STAGING_DIR)/usr/lib/mysql
+
+QT_DEP_LIBS+=mysql_client
endif
ifeq ($(BR2_PACKAGE_QT_ODBC),y)
QT_CONFIGURE+= -qt-sql-odbc