summaryrefslogtreecommitdiff
path: root/package/ruby/ruby-configure.patch
diff options
context:
space:
mode:
authorDavid Anders <dave123@abcsinc.com>2006-01-23 20:21:02 +0000
committerDavid Anders <dave123@abcsinc.com>2006-01-23 20:21:02 +0000
commit787dcdd7c72feb6e559238a7921fe25d7a22d157 (patch)
tree71a3a5aae4fba8288dba7c26485c752e0735d45b /package/ruby/ruby-configure.patch
parent59e9a3c8b8eccfcde597571fa08895f754843107 (diff)
added ruby package per case 0000566
Diffstat (limited to 'package/ruby/ruby-configure.patch')
-rw-r--r--package/ruby/ruby-configure.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/package/ruby/ruby-configure.patch b/package/ruby/ruby-configure.patch
new file mode 100644
index 000000000..ab44ebeca
--- /dev/null
+++ b/package/ruby/ruby-configure.patch
@@ -0,0 +1,29 @@
+--- ruby-1.8.3/configure.in.orig 2005-11-29 11:18:27.000000000 +0100
++++ ruby-1.8.3/configure.in 2005-11-29 11:19:46.000000000 +0100
+@@ -529,7 +529,25 @@
+ fi
+
+ AC_FUNC_GETPGRP
+-AC_FUNC_SETPGRP
++
++dnl AC_FUNC_SETPGRP does not work if cross compiling
++dnl Instead, assume we will have a prototype for setpgrp if cross compiling.
++if test "$cross_compiling" = no; then
++ AC_FUNC_SETPGRP
++else
++ AC_CACHE_CHECK([whether setpgrp takes no argument], ac_cv_func_setpgrp_void,
++ [AC_TRY_COMPILE([
++#include <unistd.h>
++], [
++ if (setpgrp(1,1) == -1)
++ exit (0);
++ else
++ exit (1);
++], ac_cv_func_setpgrp_void=no, ac_cv_func_setpgrp_void=yes)])
++if test $ac_cv_func_setpgrp_void = yes; then
++ AC_DEFINE(SETPGRP_VOID, 1)
++fi
++fi
+
+ AC_C_BIGENDIAN
+ AC_C_CONST