summaryrefslogtreecommitdiff
path: root/package/rxvt/rxvt.mk
diff options
context:
space:
mode:
authorPaul Jones <paul@pauljones.id.au>2010-06-12 09:53:51 +1000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-24 13:51:11 +0200
commitbb43b2408696787ad90450c9417a2114bbf3949b (patch)
tree9d5ef9777f8d8fb7cb28049ae2a0b3d3885530ee /package/rxvt/rxvt.mk
parent61ce3aaa64d0c56f3c3f471cac5c3514b192ce10 (diff)
Remove package rxvt
It is very old (cira 2003) and very broken Signed-off-by: Paul Jones <paul@pauljones.id.au>
Diffstat (limited to 'package/rxvt/rxvt.mk')
-rw-r--r--package/rxvt/rxvt.mk84
1 files changed, 0 insertions, 84 deletions
diff --git a/package/rxvt/rxvt.mk b/package/rxvt/rxvt.mk
deleted file mode 100644
index 3a491ca37..000000000
--- a/package/rxvt/rxvt.mk
+++ /dev/null
@@ -1,84 +0,0 @@
-#############################################################
-#
-# rxvt
-#
-#############################################################
-# Copyright (C) 2002 by Tom Walsh <Tom@OpenHardware.net>
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Library General Public License as
-# published by the Free Software Foundation; either version 2 of the
-# License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Library General Public License for more details.
-#
-# You should have received a copy of the GNU Library General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
-# USA
-
-RXVT_VERSION:=2.7.5
-RXVT_SOURCE:=rxvt-$(RXVT_VERSION).tar.gz
-RXVT_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/rxvt
-RXVT_CAT:=$(ZCAT)
-RXVT_DIR:=$(BUILD_DIR)/rxvt-$(RXVT_VERSION)
-RXVT_BINARY:=$(RXVT_DIR)/src/rxvt
-
-$(DL_DIR)/$(RXVT_SOURCE):
- $(call DOWNLOAD,$(RXVT_SITE),$(RXVT_SOURCE))
-
-rxvt-source: $(DL_DIR)/$(RXVT_SOURCE)
-
-$(RXVT_DIR)/.unpacked: $(DL_DIR)/$(RXVT_SOURCE)
- $(RXVT_CAT) $(DL_DIR)/$(RXVT_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- toolchain/patch-kernel.sh $(RXVT_DIR) package/rxvt/ \*.patch
- $(CONFIG_UPDATE) $(RXVT_DIR)/autoconf
- touch $@
-
-$(RXVT_DIR)/.configured: $(RXVT_DIR)/.unpacked
- (cd $(RXVT_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- $(TARGET_CONFIGURE_ARGS) \
- rxvt_cv_ptys=USG \
- ./configure $(QUIET) \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=$(X11_PREFIX) \
- --mandir=/usr/man \
- --infodir=/usr/info \
- --x-includes=$(STAGING_DIR)$(X11_PREFIX)/include \
- --x-libraries=$(STAGING_DIR)$(X11_PREFIX)/lib \
- --disable-resources \
- --disable-memset \
- )
- touch $@
-
-$(RXVT_BINARY): $(RXVT_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(RXVT_DIR)
- $(STRIPCMD) $(STRIP_DISCARD_ALL) $(RXVT_BINARY)
-
-$(TARGET_DIR)$(X11_PREFIX)/bin/rxvt: $(RXVT_BINARY)
- $(INSTALL) -m 0755 -D $^ $@
- (cd $(@D); ln -fs rxvt xterm)
-
-rxvt: xserver_xorg-server $(TARGET_DIR)$(X11_PREFIX)/bin/rxvt
-
-rxvt-clean:
- rm -f $(TARGET_DIR)$(X11_PREFIX)/bin/rxvt
- -$(MAKE) -C $(RXVT_DIR) clean
-
-rxvt-dirclean:
- rm -rf $(RXVT_DIR)
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_PACKAGE_RXVT),y)
-TARGETS+=rxvt
-endif