summaryrefslogtreecommitdiff
path: root/package/rxvt
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-12-22 22:10:35 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-12-22 22:10:35 +0000
commit43efac37ab9fd12a584d1969329de9794209c9a8 (patch)
tree29b4774d0214c7693c4073a82ce30bbab7b42152 /package/rxvt
parent53b07783daf19f13bf79641015bf530c2a886016 (diff)
rxvt: don't use getpt()
uClibc can be (and per default is) configured to not implement the glibc function getpt(3), so use the non-getpt rxvt configuration.
Diffstat (limited to 'package/rxvt')
-rw-r--r--package/rxvt/rxvt-2.7.5-include.patch17
-rw-r--r--package/rxvt/rxvt.mk2
2 files changed, 18 insertions, 1 deletions
diff --git a/package/rxvt/rxvt-2.7.5-include.patch b/package/rxvt/rxvt-2.7.5-include.patch
new file mode 100644
index 000000000..4ad51bbed
--- /dev/null
+++ b/package/rxvt/rxvt-2.7.5-include.patch
@@ -0,0 +1,17 @@
+uClibc doesn't have <sys/stropts.h>
+---
+ src/init.h | 1 -
+ 1 file changed, 1 deletion(-)
+
+Index: rxvt-2.7.5/src/init.h
+===================================================================
+--- rxvt-2.7.5.orig/src/init.h
++++ rxvt-2.7.5/src/init.h
+@@ -16,7 +16,6 @@
+
+ #if defined(PTYS_ARE_PTMX) && !defined(__CYGWIN32__)
+ # include <sys/resource.h> /* for struct rlimit */
+-# include <sys/stropts.h> /* for I_PUSH */
+ # define _NEW_TTY_CTRL /* to get proper defines in <termios.h> */
+ #endif
+
diff --git a/package/rxvt/rxvt.mk b/package/rxvt/rxvt.mk
index 2cf1fad89..e28d7dfc7 100644
--- a/package/rxvt/rxvt.mk
+++ b/package/rxvt/rxvt.mk
@@ -42,7 +42,7 @@ $(RXVT_DIR)/.configured: $(RXVT_DIR)/.unpacked
(cd $(RXVT_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
$(TARGET_CONFIGURE_ARGS) \
- rxvt_cv_ptys=GLIBC \
+ rxvt_cv_ptys=USG \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \