summaryrefslogtreecommitdiff
path: root/package/samba/samba.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-30 10:21:40 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-30 10:21:40 +0200
commit074b6689e81d5bc4abf08d63dc8086b9cc41a078 (patch)
tree8cff99d679b7260a54cebac38af0764b16394b71 /package/samba/samba.mk
parent18abd4aa94cd59240b90257c95877c0ea2fd1796 (diff)
parente7584697f24d0bc6fc660703d97a38598cb76690 (diff)
Merge branch 'fixes-20100729' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'package/samba/samba.mk')
-rw-r--r--package/samba/samba.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/samba/samba.mk b/package/samba/samba.mk
index 1c59070d4..44f7fdeff 100644
--- a/package/samba/samba.mk
+++ b/package/samba/samba.mk
@@ -161,6 +161,17 @@ $(SAMBA_HOOK_POST_INSTALL):
# remove unneeded
rm -f $(addprefix $(TARGET_DIR)/, $(SAMBA_BINTARGETS_))
rm -f $(addprefix $(TARGET_DIR)/, $(SAMBA_TXTTARGETS_))
+ifeq ($(BR2_PACKAGE_SAMBA_SWAT),y)
+ifneq ($(BR2_HAVE_DOCUMENTATION),y)
+ # Remove the documentation
+ rm -rf $(TARGET_DIR)/usr/swat/help/manpages
+ rm -rf $(TARGET_DIR)/usr/swat/help/Samba3*
+ rm -rf $(TARGET_DIR)/usr/swat/using_samba/
+ # Removing the welcome.html file will make swat default to
+ # welcome-no-samba-doc.html
+ rm -rf $(TARGET_DIR)/usr/swat/help/welcome.html
+endif
+endif
# strip binaries
$(STRIPCMD) $(STRIP_STRIP_ALL) $(addprefix $(TARGET_DIR)/, $(SAMBA_BINTARGETS_y))
# install start/stop script