summaryrefslogtreecommitdiff
path: root/package/squashfs3/squashfs3.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-04-09 16:17:57 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-04-09 16:17:57 +0200
commit3f583771a42fab0eb0bb627d1a0e91eb542df287 (patch)
tree2b107946e876e5b789b79d42ef229e651f2bc786 /package/squashfs3/squashfs3.mk
parent6bb35a38c244b20bbd6e85fd16f69ff2c4f0ed72 (diff)
parentb8cee9fb4380a8d58a324d141dcab68a4c3aa29c (diff)
Merge branch 'squashfs3' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'package/squashfs3/squashfs3.mk')
-rw-r--r--package/squashfs3/squashfs3.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/squashfs3/squashfs3.mk b/package/squashfs3/squashfs3.mk
new file mode 100644
index 000000000..5504b1426
--- /dev/null
+++ b/package/squashfs3/squashfs3.mk
@@ -0,0 +1,30 @@
+SQUASHFS3_VERSION=3.4
+SQUASHFS3_SOURCE=squashfs$(SQUASHFS3_VERSION).tar.gz
+SQUASHFS3_SITE=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/squashfs
+
+SQUASHFS3_DEPENDENCIES = zlib
+HOST_SQUASHFS3_DEPENDENCIES = host-zlib
+
+define SQUASHFS3_BUILD_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) \
+ CC="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="$(TARGET_LDFLAGS)" \
+ -C $(@D)/squashfs-tools/
+endef
+
+define SQUASHFS3_INSTALL_TARGET_CMDS
+ $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)/squashfs-tools/ INSTALL_DIR=$(TARGET_DIR)/usr/bin install
+endef
+
+define HOST_SQUASHFS3_BUILD_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/squashfs-tools/
+endef
+
+define HOST_SQUASHFS3_INSTALL_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/squashfs-tools/ INSTALL_DIR=$(HOST_DIR)/usr/bin install
+endef
+
+$(eval $(call GENTARGETS,package,squashfs3))
+$(eval $(call GENTARGETS,package,squashfs3,host))
+