summaryrefslogtreecommitdiff
path: root/package/squid/squid.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-16 13:25:32 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-16 13:36:00 +0200
commit1860bdae8cdf4f9eb7097fd7e5ed7e9c0c5b6a75 (patch)
treeb3b4fb6139799602676e100126c19055b18ac7f0 /package/squid/squid.mk
parentc106fdbd100f36fe3329360af8f656566937f00a (diff)
parentae2be8dbc36293d8243baf2b13ad17a47738d6d3 (diff)
Merge branch 'for-2010.11/remove-oldstyle-hooks' of git://git.busybox.net/~tpetazzoni/git/buildroot
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/squid/squid.mk')
-rw-r--r--package/squid/squid.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/package/squid/squid.mk b/package/squid/squid.mk
index 6e94d5011..6254b843c 100644
--- a/package/squid/squid.mk
+++ b/package/squid/squid.mk
@@ -23,13 +23,15 @@ ifeq ($(BR2_PACKAGE_OPENSSL),y)
SQUID_DEPENDENCIES += openssl
endif
-$(eval $(call AUTOTARGETS,package,squid))
-
-$(SQUID_HOOK_POST_INSTALL):
+define SQUID_CLEANUP_TARGET
rm -f $(addprefix $(TARGET_DIR)/usr/bin/, \
RunCache RunAccel)
rm -f $(addprefix $(TARGET_DIR)/etc/, \
cachemgr.conf mime.conf.default squid.conf.default)
rm -f $(TARGET_DIR)/usr/libexec/cachemgr.cgi
rm -f $(TARGET_DIR)/usr/share/mib.txt
- touch $@
+endef
+
+SQUID_POST_INSTALL_TARGET_HOOKS += SQUID_CLEANUP_TARGET
+
+$(eval $(call AUTOTARGETS,package,squid))