summaryrefslogtreecommitdiff
path: root/package/tinyx/tinyx.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/tinyx/tinyx.mk
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/tinyx/tinyx.mk')
-rw-r--r--package/tinyx/tinyx.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/tinyx/tinyx.mk b/package/tinyx/tinyx.mk
index 24845455d..3f7d5328f 100644
--- a/package/tinyx/tinyx.mk
+++ b/package/tinyx/tinyx.mk
@@ -125,3 +125,11 @@ tinyx-clean:
tinyx-dirclean:
-rm -rf $(TINYX_DIR)
-rm -rf $(TARGET_DIR)/usr/X11R6
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_TINYX)),y)
+TARGETS+=tinyx
+endif