summaryrefslogtreecommitdiff
path: root/package/util-linux
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 02:49:33 +0000
commit44eedc5c44416a97b3f5ca03d596ec3c9fb29380 (patch)
tree96f605b4cd9934fc1d09319490c672aaab44ce2f /package/util-linux
parent73f7be82904f487d167493e76b415fbe5b5f8c5a (diff)
facelift step number two
Diffstat (limited to 'package/util-linux')
-rw-r--r--package/util-linux/util-linux.mk2
-rw-r--r--package/util-linux/util-linux.patch28
2 files changed, 29 insertions, 1 deletions
diff --git a/package/util-linux/util-linux.mk b/package/util-linux/util-linux.mk
index 1cc828bcd..82c0309d5 100644
--- a/package/util-linux/util-linux.mk
+++ b/package/util-linux/util-linux.mk
@@ -20,7 +20,7 @@ $(DL_DIR)/$(UTIL-LINUX_PATCH):
$(UTIL-LINUX_DIR)/.unpacked: $(DL_DIR)/$(UTIL-LINUX_SOURCE) $(DL_DIR)/$(UTIL-LINUX_PATCH)
$(UTIL-LINUX_CAT) $(DL_DIR)/$(UTIL-LINUX_SOURCE) | tar -C $(BUILD_DIR) -xvf -
$(UTIL-LINUX_CAT) $(DL_DIR)/$(UTIL-LINUX_PATCH) | patch -p1 -d $(UTIL-LINUX_DIR)
- cat $(SOURCE_DIR)/util-linux.patch | patch -p1 -d $(UTIL-LINUX_DIR)
+ toolchain/patch-kernel.sh $(UTIL-LINUX_DIR) package/util-linux/ util-linux*.patch
touch $(UTIL-LINUX_DIR)/.unpacked
$(UTIL-LINUX_DIR)/.configured: $(UTIL-LINUX_DIR)/.unpacked
diff --git a/package/util-linux/util-linux.patch b/package/util-linux/util-linux.patch
new file mode 100644
index 000000000..601e7dc11
--- /dev/null
+++ b/package/util-linux/util-linux.patch
@@ -0,0 +1,28 @@
+--- util-linux-2.11z/mount/fstab.c.orig 2003-12-03 15:28:22.000000000 -0700
++++ util-linux-2.11z/mount/fstab.c 2003-12-03 15:28:41.000000000 -0700
+@@ -342,7 +342,7 @@
+ /* Ensure that the lock is released if we are interrupted. */
+ static void
+ handler (int sig) {
+- die (EX_USER, "%s", sys_siglist[sig]);
++ die (EX_USER, "%s", strsignal(sig));
+ }
+
+ static void
+--- /dev/null 2003-09-07 01:55:59.000000000 -0600
++++ util-linux-2.11z/mount/swapargs.h 2003-12-03 15:44:50.000000000 -0700
+@@ -0,0 +1,3 @@
++#define SWAPON_HAS_TWO_ARGS
++#include <asm/page.h>
++#include <sys/swap.h>
+--- util-linux-2.11z/mount/swap.configure.orig 2003-12-03 15:43:24.000000000 -0700
++++ util-linux-2.11z/mount/swap.configure 2003-12-03 15:45:33.000000000 -0700
+@@ -1,6 +1,8 @@
+ # Find out whether we can include <sys/swap.h>
+ # and whether libc thinks that swapon() has two arguments.
+
++exit 0
++
+ # Prepare test
+ CC=${CC-cc}
+ compile="$CC -o conftest conftest.c >/dev/null 2>&1"