summaryrefslogtreecommitdiff
path: root/package/vice
diff options
context:
space:
mode:
authorJohn Voltz <john.voltz@gmail.com>2008-03-06 18:28:26 +0000
committerJohn Voltz <john.voltz@gmail.com>2008-03-06 18:28:26 +0000
commit70b2460ed994b85fe8904ab8e79dda8a782e5e5b (patch)
treebf4f8f081d78013e2a39e1570f24420746f375a8 /package/vice
parent9fc65734f8843c3a3ea33ef523133d4fbfcd6cab (diff)
added vice
Diffstat (limited to 'package/vice')
-rw-r--r--package/vice/Config.in7
-rw-r--r--package/vice/vice-1.22-remove-bzero.patch20
-rw-r--r--package/vice/vice.mk18
3 files changed, 45 insertions, 0 deletions
diff --git a/package/vice/Config.in b/package/vice/Config.in
new file mode 100644
index 000000000..20ca3dc27
--- /dev/null
+++ b/package/vice/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_VICE
+ bool "vice"
+ default n
+ help
+ VICE is a Commodore emulator
+
+ http://www.viceteam.org/online
diff --git a/package/vice/vice-1.22-remove-bzero.patch b/package/vice/vice-1.22-remove-bzero.patch
new file mode 100644
index 000000000..5836a9fce
--- /dev/null
+++ b/package/vice/vice-1.22-remove-bzero.patch
@@ -0,0 +1,20 @@
+--- a/src/network.c 2007-07-15 18:49:24.000000000 -0400
++++ b/src/network.c 2008-03-01 21:29:40.000000000 -0500
+@@ -742,7 +742,7 @@ int network_start_server(void)
+
+ #ifdef HAVE_IPV6
+ if (netplay_ipv6) {
+- bzero((char*)&server_addr6, sizeof(struct sockaddr_in6));
++ memset((char*)&server_addr6, 0, sizeof(struct sockaddr_in6));
+ server_addr6.sin6_port = htons(server_port);
+ server_addr6.sin6_family = PF_INET6;
+ server_addr6.sin6_addr=in6addr_any;
+@@ -853,7 +853,7 @@ int network_connect_client(void)
+ }
+ #ifdef HAVE_IPV6
+ if (netplay_ipv6) {
+- bzero((char*)&server_addr6, sizeof(struct sockaddr_in6));
++ memset((char*)&server_addr6, 0, sizeof(struct sockaddr_in6));
+ server_addr6.sin6_port = htons(server_port);
+ server_addr6.sin6_family = PF_INET6;
+ memcpy(&server_addr6.sin6_addr, server_hostent->h_addr, server_hostent->h_length);
diff --git a/package/vice/vice.mk b/package/vice/vice.mk
new file mode 100644
index 000000000..a45910e48
--- /dev/null
+++ b/package/vice/vice.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# vice
+#
+#############################################################
+VICE_VERSION = 1.22
+VICE_SOURCE = vice-$(VICE_VERSION).tar.gz
+VICE_SITE = http://www.viceteam.org/online
+VICE_AUTORECONF = NO
+VICE_INSTALL_STAGING = NO
+VICE_INSTALL_TARGET = YES
+
+VICE_CONF_OPT = --without-resid --with-alsa CFLAGS="-O0"
+
+VICE_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package,vice))
+