summaryrefslogtreecommitdiff
path: root/package/webkit/webkit.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-21 16:25:58 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-02-23 20:34:56 +0100
commit09216ec22b2590b0e5fb5f50ed98bc0f6fd313d5 (patch)
tree373d77f0bfa3340a707bd32c9bbac87f2438d015 /package/webkit/webkit.mk
parent1cd56dc514cc4da46cd7abc1782fe258ae1b3dcb (diff)
webkit: several build fixes
This patch fixes different problems: * The autogen script of Webkit did not find autoconf, automake and aclocal since they are not installed in the host, but in $(HOST_DIR). Therefore we pass HOST_CONFIGURE_OPTS to autogen.sh so that the PATH is correct. * The autogen script was complaining that gtk-doc.make could not be find. As compiling gtk-doc completely is a pain (depends on Docbook), we just include gtk-doc.make into package/webkit/, and copy it to the source directory. * The autogen script was complaining about macros used in gtk-doc.make that did not exist. This is because aclocal was not run with $(STAGING_DIR)/usr/share/aclocal/ in the include path. Therefore, we fix ACLOCAL_FLAGS of Webkit's autogen script before running it. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/webkit/webkit.mk')
-rw-r--r--package/webkit/webkit.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/webkit/webkit.mk b/package/webkit/webkit.mk
index 389a5fc25..2121f4b06 100644
--- a/package/webkit/webkit.mk
+++ b/package/webkit/webkit.mk
@@ -25,10 +25,12 @@ endif
WEBKIT_CONF_OPT += --disable-video
define WEBKIT_AUTOGEN_PATCH
+$(SED) 's%ACLOCAL_FLAGS=.*%ACLOCAL_FLAGS="-I autotools -I $(STAGING_DIR)/usr/share/aclocal"%' $(WEBKIT_DIR)/autogen.sh
$(SED) 's/AUTOMAKE_FLAGS=.*/AUTOMAKE_FLAGS="--foreign --add-missing --copy"/' $(WEBKIT_DIR)/autogen.sh
$(SED) 's/LIBTOOLIZE_FLAGS=.*/LIBTOOLIZE_FLAGS="--force --automake --copy"/' $(WEBKIT_DIR)/autogen.sh
+cp package/webkit/gtk-doc.make $(WEBKIT_DIR)/
# Don't run the configure step yet
-cd $(WEBKIT_DIR); AUTOGEN_CONFIGURE_ARGS=--version ./autogen.sh
+cd $(WEBKIT_DIR); $(HOST_CONFIGURE_OPTS) AUTOGEN_CONFIGURE_ARGS=--version ./autogen.sh
endef
WEBKIT_POST_EXTRACT_HOOKS += WEBKIT_AUTOGEN_PATCH