summaryrefslogtreecommitdiff
path: root/package/xorg
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-07-13 07:36:40 +0000
committerEric Andersen <andersen@codepoet.org>2005-07-13 07:36:40 +0000
commit0e2290174222f21e029d2ee1b4f735b81d2e8a77 (patch)
tree5bae26cd846dc4a796c177a7a235a57d413e6a9c /package/xorg
parentdadad95190710ae2e7c2c0cc9cacf5541f99c6f7 (diff)
Fix some stupid bugs in the Xorg build
Diffstat (limited to 'package/xorg')
-rw-r--r--package/xorg/xorg-config.patch2
-rw-r--r--package/xorg/xorg.mk4
2 files changed, 5 insertions, 1 deletions
diff --git a/package/xorg/xorg-config.patch b/package/xorg/xorg-config.patch
index 87e836f27..9c92ed12c 100644
--- a/package/xorg/xorg-config.patch
+++ b/package/xorg/xorg-config.patch
@@ -73,7 +73,7 @@
#undef PostIncDir
-#define PostIncDir /skiff/local/lib/gcc-lib/arm-linux/2.95.2/include
-#define CcCmd /skiff/local/bin/arm-linux-gcc
-+#define PostIncDir REPLACE_STAGING_DIR/lib/gcc-lib/REPLACE_ARCH-linux-uclibc/3.3.3/include
++#define PostIncDir REPLACE_GCCINC_DIR
+#define CcCmd REPLACE_STAGING_DIR/bin/REPLACE_ARCH-linux-gcc
#undef CplusplusCmd
-#define HasCplusplus YES
diff --git a/package/xorg/xorg.mk b/package/xorg/xorg.mk
index 59a6b76df..9c2549e5c 100644
--- a/package/xorg/xorg.mk
+++ b/package/xorg/xorg.mk
@@ -42,11 +42,15 @@ $(DL_DIR)/$(XORG_SOURCE):
$(XORG_DIR)/.configure: $(DL_DIR)/$(XORG_SOURCE)
$(XORG_CAT) $(DL_DIR)/$(XORG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(XORG_DIR) package/xorg/ xorg\*.patch
+ $(SED) 's:REPLACE_GCCINC_DIR:$(shell $(TARGET_CROSS)gcc -print-file-name=include):g' $(XORG_CF)
$(SED) 's:REPLACE_STAGING_DIR:$(STAGING_DIR):g' $(XORG_CF)
$(SED) 's:REPLACE_ARCH:$(ARCH):g' $(XORG_CF)
$(SED) 's:#define CcCmd.*:#define CcCmd $(TARGET_CROSS)gcc:g' $(XORG_CF)
$(SED) 's:#define RanlibCmd.*:#define RanlibCmd $(TARGET_CROSS)ranlib:g' $(XORG_CF)
$(SED) 's:#define LdCmd.*:#define LdCmd $(TARGET_CROSS)ld:g' $(XORG_CF)
+ $(SED) 's:#.*define.*HasPam.*YES::g' $(XORG_DIR)/config/cf/linux.cf
+ $(SED) 's:#.*define.*CrossCompiling.*NO:#define CrossCompiling YES:g' $(XORG_DIR)/config/cf/Imake.tmpl
+ $(SED) 's:#.*undef.*CrossCompileDir.*:#define CrossCompileDir$(STAGING_DIR)/bin:g' $(XORG_DIR)/config/cf/Imake.tmpl
touch $(XORG_DIR)/.configure
$(XORG_XSERVER): $(XORG_DIR)/.configure