summaryrefslogtreecommitdiff
path: root/package/yajl/yajl-2.0.4-math-link.patch
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-01-25 12:03:10 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-25 12:03:10 +0100
commit01e5bee40f7ae083a5d62c99667bb9709d266f16 (patch)
treeb034f47c1125250da52d3cabedea22efac78bca3 /package/yajl/yajl-2.0.4-math-link.patch
parent0d2a304ef39fa838824b31e4453dcef21b5302ff (diff)
yajl: bump version
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/yajl/yajl-2.0.4-math-link.patch')
-rw-r--r--package/yajl/yajl-2.0.4-math-link.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/yajl/yajl-2.0.4-math-link.patch b/package/yajl/yajl-2.0.4-math-link.patch
new file mode 100644
index 000000000..355a24856
--- /dev/null
+++ b/package/yajl/yajl-2.0.4-math-link.patch
@@ -0,0 +1,24 @@
+[PATCH] fix json_reformat linking on uClibc
+
+json_reformat calls yajl_gen_* functions, which internally use isnan() /
+isinf(). On Glibc, these are provided by libc, but on uClibc you need to
+link with -lm (like the spec says), so ensure we do so.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ reformatter/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: yajl-2.0.2/reformatter/CMakeLists.txt
+===================================================================
+--- yajl-2.0.2.orig/reformatter/CMakeLists.txt
++++ yajl-2.0.2/reformatter/CMakeLists.txt
+@@ -26,7 +26,7 @@
+
+ ADD_EXECUTABLE(json_reformat ${SRCS})
+
+-TARGET_LINK_LIBRARIES(json_reformat yajl_s)
++TARGET_LINK_LIBRARIES(json_reformat yajl_s m)
+
+ # copy the binary into the output directory
+ GET_TARGET_PROPERTY(binPath json_reformat LOCATION)