summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-26 14:02:29 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-26 14:02:29 +0000
commitc77052465aa657b8256a36853d8be08093012072 (patch)
tree1c86a68a46144fbee481052d4dd7acacc6aade4d /package
parent0abc368c5ce6454aafe36f3cbe124225c89133ff (diff)
- pass -msoft-float if BR2_SOFT_FLOAT is set. Closes bug #1069
Diffstat (limited to 'package')
-rw-r--r--package/Makefile.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index b619105bf..6b1e6fe19 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -34,11 +34,19 @@ ifeq ($(BR2_x86_64),y)
TARGET_CFLAGS+=-fPIC -DPIC
endif # PIC for dynamic objects on x86_64
endif
+
+ifeq ($(BR2_SOFT_FLOAT),y)
+TARGET_CFLAGS+=-msoft-float
+endif
+
+
# else it's an external toolchain
+#########################################################################
else
TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING) -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include -I$(TOOLCHAIN_EXTERNAL_PATH)/$(TOOLCHAIN_EXTERNAL_PREFIX)/include
TARGET_LDFLAGS=-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib
endif
+#########################################################################
ifndef HOSTAR
HOSTAR:=ar