summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>2010-05-09 15:19:10 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-22 22:11:19 +0200
commit6bd9ca56d9f2eba062e09b4650c1d2b66375b199 (patch)
treee80f08af6c46516c9f4653535d2edf99072b7962 /package
parent288d76be8a6ee075247d388a494db0d768fc748f (diff)
package/config: really clean
Signed-off-by: Yann E. MORIN <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package')
-rw-r--r--package/config/Makefile.kconfig13
1 files changed, 9 insertions, 4 deletions
diff --git a/package/config/Makefile.kconfig b/package/config/Makefile.kconfig
index 6974cc3b5..6d89e597e 100644
--- a/package/config/Makefile.kconfig
+++ b/package/config/Makefile.kconfig
@@ -149,10 +149,15 @@ ifeq ($(gconf-target),1)
gconf-objs := gconf.o kconfig_load.o zconf.tab.o
endif
-clean-files := lkc_defs.h qconf.moc .tmp_qtcheck \
- .tmp_gtkcheck zconf.tab.c lex.zconf.c zconf.hash.c gconf.glade.h
-clean-files += mconf qconf gconf
-clean-files += config.pot linux.pot
+clean-files := lkc_defs.h qconf.moc .tmp_qtcheck \
+ .tmp_gtkcheck zconf.tab.c lex.zconf.c zconf.hash.c gconf.glade.h
+clean-files += config.pot linux.pot
+clean-files += conf $(conf-objs)
+clean-files += mconf $(mconf-objs)
+clean-files += qconf qconf.o
+clean-files += gconf gconf.o
+clean-files += kconfig_load.o zconf.tab.o
+clean-files += $(kxgettext-objs)
# Check that we have the required ncurses stuff installed for lxdialog (menuconfig)
PHONY += $(obj)/dochecklxdialog