summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-28 23:40:42 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-02 23:24:21 +0200
commit7dfa3b3fb42adabe5bbf36ea32909f427561ca59 (patch)
tree76ed0c3284c39c556b3ba15a97ca8ffcce143284 /package
parent8471827f32e92c12e90ba2a534d00873845617c2 (diff)
autotools: fix autoreconf check
The autoreconf check was incorrect, missing a $ sign to properly reference a package-specific variable. There was no visible effect until now since : * The existing syntax allowed to access the value defined in the package specific .mk file, so when AUTORECONF was set to YES by a package, it was working. * The default value in Makefile.autotools.in was NO. In fact, when a package .mkf file wasn't defining the AUTORECONF variable, the Makefile.autotools.in test was testing the empty string against 'YES', which was false, leading to the AUTORECONF not being done, which was the desired effect. However, in a later patch, we intend to change this default value. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package')
-rw-r--r--package/Makefile.autotools.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index b7a710359..fc5bcee34 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -162,7 +162,7 @@ define AUTORECONF_HOOK
fi
endef
-ifeq ($($(2)_AUTORECONF),YES)
+ifeq ($$($(2)_AUTORECONF),YES)
$(2)_POST_PATCH_HOOKS += AUTORECONF_HOOK
$(2)_DEPENDENCIES += host-automake host-autoconf host-libtool
endif