summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-05-21 08:53:34 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-21 08:53:34 +0200
commitbb81787ae1f8b1d8c513f42766c2155b66feaf84 (patch)
tree3c2219b6ad8f802882a2d5954e3a69a3c152c7d8 /package
parent484d15dea6f3175eb5b999592a7f4bb9d101c68a (diff)
qt: update x86x86fix for 32bit pc hosts
The recent change to use config.guess to figure out GNU_HOST_NAME broken the x86x86fix detection for 32bit hosts, as config.guess returns something like i686-pc-linux-gnu rather than something with *-unknown-linux-* like we used to use. Fix it by simply looking for "linux" instead. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package')
-rw-r--r--package/qt/qt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 4f42e59e8..aaf965e3c 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -372,7 +372,7 @@ BR2_PACKAGE_QT_EMB_PLATFORM:=$(call qstrip,$(BR2_PACKAGE_QT_EMB_PLATFORM))
# x86x86fix
# Workaround Qt Embedded bug when crosscompiling for x86 under x86 with linux
# host. It's unclear if this would happen on other hosts.
-ifneq ($(findstring unknown-linux,$(GNU_HOST_NAME)),)
+ifneq ($(findstring linux,$(GNU_HOST_NAME)),)
ifneq ($(findstring x86,$(BR2_PACKAGE_QT_EMB_PLATFORM)),)
QT_CONFIGURE+= -platform linux-g++
endif