summaryrefslogtreecommitdiff
path: root/project
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:06:47 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:06:47 +0000
commite7b38c71ce55720f7709f0049f5bfc71ca0615ec (patch)
tree2ce70187ad1380f02c1777e7da3a48fb16d9f26a /project
parentf58ff9a25f24576e032c65d762e5b8fdd2cf5c1c (diff)
package: add STAMP_DIR and use for host builds
Move stamp (dependency) files outside the (version specific) source directories, so other packages can hardcode dependencies on them instead of having to use <PACKAGE>_VERSION variables. This is important as the variables in the make rules are evaluated when the rules is seen, which might be before the dependent makefile is parsed (and hence <PACKAGE>_VERSION variable is known, screwing up stuff. The downside of this is that the package isn't automatically rebuilt when the version changes (E.G. by a svn update) and you now also have to remove the stamp files next to $(BUILD_DIR)/<PACKAGE>-* to force a rebuild.
Diffstat (limited to 'project')
-rw-r--r--project/Makefile.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/project/Makefile.in b/project/Makefile.in
index a3a666493..49aec141a 100644
--- a/project/Makefile.in
+++ b/project/Makefile.in
@@ -71,6 +71,9 @@ STAGING_DIR:=$(strip $(subst ",, $(BR2_STAGING_DIR)))
# packages compiled for the host goes here
HOST_DIR:=$(BUILD_DIR)/host_dir
+# stamp (dependency) files go here
+STAMP_DIR:=$(BUILD_DIR)/stamps
+
# All configurable packages (like Busybox,Linux etc) should be built
# in PROJECT_BUILD_DIR
PROJECT_BUILD_DIR:=$(BASE_DIR)/$(TOPDIR_PREFIX)project_build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_SUFFIX)/$(PROJECT)