summaryrefslogtreecommitdiff
path: root/project
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-10-21 08:56:26 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-10-21 08:56:26 +0000
commit43af3d35781855cfa987ef163e4c75d8e52f5be0 (patch)
tree5acff845bcd55b71939a28e53e1f98686c7289f4 /project
parent02cfe523e886c6c619501df7b851634032505e30 (diff)
buildroot: add QUIET variable and use it for wget/git/svn/configure
A lot of tools take a -q option to be quiet. Set this if make is called with the -s (silent) option and use for wget, git, svn and configure.
Diffstat (limited to 'project')
-rw-r--r--project/Makefile.in11
1 files changed, 6 insertions, 5 deletions
diff --git a/project/Makefile.in b/project/Makefile.in
index cc1043ba1..fc73e407b 100644
--- a/project/Makefile.in
+++ b/project/Makefile.in
@@ -5,17 +5,19 @@ TARGET_HOSTNAME:=$(strip $(subst ",,$(BR2_HOSTNAME)))
BANNER:=$(strip $(subst ",,$(BR2_BANNER)))
#"))
+# silent mode requested?
+QUIET:=$(if $(findstring s,$(MAKEFLAGS)),-q,)
# Strip off the annoying quoting
ARCH:=$(strip $(subst ",, $(BR2_ARCH)))
#"))
-WGET:=$(strip $(subst ",, $(BR2_WGET))) $(SPIDER)
+WGET:=$(strip $(subst ",, $(BR2_WGET))) $(SPIDER) $(QUIET)
#"))
-SVN_CO:=$(strip $(subst ",, $(BR2_SVN_CO)))
+SVN_CO:=$(strip $(subst ",, $(BR2_SVN_CO))) $(QUIET)
#"))
-SVN_UP:=$(strip $(subst ",, $(BR2_SVN_UP)))
+SVN_UP:=$(strip $(subst ",, $(BR2_SVN_UP))) $(QUIET)
#"))
-GIT:=$(strip $(subst ",, $(BR2_GIT)))
+GIT:=$(strip $(subst ",, $(BR2_GIT))) $(QUIET)
#"))
ZCAT:=$(strip $(subst ",, $(BR2_ZCAT)))
#"))
@@ -24,7 +26,6 @@ BZCAT:=$(strip $(subst ",, $(BR2_BZCAT)))
TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
#")
-
# Buildroot supports building out of tree similarly to the Linux kernel.
# To use, add O= to the make command line (make O=/tmp/build)
BASE_DIR:=$(shell pwd)