summaryrefslogtreecommitdiff
path: root/project
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-16 15:48:43 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-16 15:48:43 +0000
commitbd07d92aaddd32f7648d7e1f59d34a41019d4744 (patch)
treed9048893afe5fc4b7679aecec482ec43346ad946 /project
parentad529c62b2af4a81e493cb571af31f2fe5694bd1 (diff)
Makefile: introduce $(HOST_DIR) for host binaries
Add HOST_DIR directory handling. HOST_DIR should be used just like STAGING_DIR, but for host files instead of target ones.
Diffstat (limited to 'project')
-rw-r--r--project/Makefile.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/project/Makefile.in b/project/Makefile.in
index fc73e407b..a3a666493 100644
--- a/project/Makefile.in
+++ b/project/Makefile.in
@@ -68,6 +68,9 @@ GNU_TARGET_SUFFIX:=-$(strip $(subst ",, $(BR2_GNU_TARGET_SUFFIX)))
STAGING_DIR:=$(strip $(subst ",, $(BR2_STAGING_DIR)))
#"))
+# packages compiled for the host goes here
+HOST_DIR:=$(BUILD_DIR)/host_dir
+
# All configurable packages (like Busybox,Linux etc) should be built
# in PROJECT_BUILD_DIR
PROJECT_BUILD_DIR:=$(BASE_DIR)/$(TOPDIR_PREFIX)project_build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_SUFFIX)/$(PROJECT)