summaryrefslogtreecommitdiff
path: root/project
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-14 07:45:01 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-08-14 07:45:01 +0000
commitf958d89724e5db98943e28c2dda45a86f27e6401 (patch)
tree063c1812c12079c9b79405cf8fc078768f7debf8 /project
parent74cda1e49b8c0d3ee6d6069452cfc74ab8f9a536 (diff)
Move project related info from main Makefile to project dir
Diffstat (limited to 'project')
-rw-r--r--project/Makefile.in6
-rw-r--r--project/project.mk14
2 files changed, 20 insertions, 0 deletions
diff --git a/project/Makefile.in b/project/Makefile.in
new file mode 100644
index 000000000..b90f31267
--- /dev/null
+++ b/project/Makefile.in
@@ -0,0 +1,6 @@
+PROJECT:=$(strip $(subst ",,$(BR2_PROJECT)))
+#"))
+TARGET_HOSTNAME:=$(strip $(subst ",,$(BR2_HOSTNAME)))
+#"))
+BANNER:=$(strip $(subst ",,$(BR2_BANNER)))
+#"))
diff --git a/project/project.mk b/project/project.mk
new file mode 100644
index 000000000..b33f90181
--- /dev/null
+++ b/project/project.mk
@@ -0,0 +1,14 @@
+
+.PHONY: target-host-info
+
+target-host-info: $(TARGET_DIR)/etc/issue $(TARGET_DIR)/etc/hostname
+
+$(TARGET_DIR)/etc/issue: .config
+ mkdir -p $(TARGET_DIR)/etc
+ echo "" > $(TARGET_DIR)/etc/issue
+ echo "" >> $(TARGET_DIR)/etc/issue
+ echo "$(BANNER)" >> $(TARGET_DIR)/etc/issue
+
+$(TARGET_DIR)/etc/hostname: .config
+ mkdir -p $(TARGET_DIR)/etc
+ echo "$(TARGET_HOSTNAME)" > $(TARGET_DIR)/etc/hostname