summaryrefslogtreecommitdiff
path: root/sources/ltp-testsuite.patch
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-10-06 08:06:02 +0000
committerEric Andersen <andersen@codepoet.org>2003-10-06 08:06:02 +0000
commitc1846604edf7794dfb451600cdbce1466c929c80 (patch)
tree06f15065c243598092b60325bfcf437d4d5c1e7e /sources/ltp-testsuite.patch
parent1d669278d8aa2a78e372a914277e27754e4cca79 (diff)
Add the linux test project test suite. The 'make install' step is currently
broken, since I've not worked out how I want to handle that step (it wants to run as root).
Diffstat (limited to 'sources/ltp-testsuite.patch')
-rw-r--r--sources/ltp-testsuite.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/sources/ltp-testsuite.patch b/sources/ltp-testsuite.patch
new file mode 100644
index 000000000..689037556
--- /dev/null
+++ b/sources/ltp-testsuite.patch
@@ -0,0 +1,55 @@
+--- ltp-full-20031002/testcases/kernel/syscalls/fmtmsg/Makefile.orig 2003-10-02 19:18:10.000000000 -0600
++++ ltp-full-20031002/testcases/kernel/syscalls/fmtmsg/Makefile 2003-10-02 19:18:32.000000000 -0600
+@@ -24,7 +24,7 @@
+ LOADLIBES+= -L../../../../lib -lltp
+
+ SRCS=$(wildcard *.c)
+-TARGETS=$(patsubst %.c,%,$(SRCS))
++TARGETS=#$(patsubst %.c,%,$(SRCS))
+
+ all: $(TARGETS)
+
+--- ltp-full-20031002/testcases/kernel/syscalls/mallopt/Makefile.orig 2003-10-02 19:20:52.000000000 -0600
++++ ltp-full-20031002/testcases/kernel/syscalls/mallopt/Makefile 2003-10-02 19:21:07.000000000 -0600
+@@ -23,7 +23,7 @@
+ LOADLIBES+= -L../../../../lib -lltp
+
+ SRCS=$(wildcard *.c)
+-TARGETS=$(patsubst %.c,%,$(SRCS))
++TARGETS=#$(patsubst %.c,%,$(SRCS))
+
+ all: $(TARGETS)
+
+--- ltp-full-20031002/testcases/kernel/syscalls/profil/Makefile.orig 2003-10-02 19:27:53.000000000 -0600
++++ ltp-full-20031002/testcases/kernel/syscalls/profil/Makefile 2003-10-02 19:28:02.000000000 -0600
+@@ -23,7 +23,7 @@
+ LOADLIBES+= -L../../../../lib -lltp
+
+ SRCS=$(wildcard *.c)
+-TARGETS=$(patsubst %.c,%,$(SRCS))
++TARGETS=#$(patsubst %.c,%,$(SRCS))
+
+ all: $(TARGETS)
+
+--- ltp-full-20031002/testcases/network/rpc/rpc01/Makefile.orig 2003-10-02 19:36:51.000000000 -0600
++++ ltp-full-20031002/testcases/network/rpc/rpc01/Makefile 2003-10-02 19:37:03.000000000 -0600
+@@ -2,7 +2,7 @@
+ LDLIBS +=
+
+ SRCS=$(wildcard *.c)
+-TARGETS=$(patsubst %.c,%,$(SRCS))
++TARGETS=#$(patsubst %.c,%,$(SRCS))
+
+ all: $(TARGETS)
+
+--- ltp-full-20031002/tools/netpipe-2.4-ipv6/Makefile.orig 2003-10-02 19:38:07.000000000 -0600
++++ ltp-full-20031002/tools/netpipe-2.4-ipv6/Makefile 2003-10-02 19:38:38.000000000 -0600
+@@ -10,7 +10,7 @@
+ DRIV_OBJ = netpipe.o
+ INCLUDES = netpipe.h
+ # Default target is just TCP
+-TARGETS = NPtcp-ipv6
++TARGETS = #NPtcp-ipv6
+ # If you have TCP, MPI and PVM
+ #TARGETS = NPtcp NPmpi NPpvm
+ CFLAGS += -O -Wall