summaryrefslogtreecommitdiff
path: root/target/Makefile.in
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-26 23:52:31 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-26 23:52:31 +0000
commit0dbf9dd7ab8e08e9081a1141f0122f0e2cdc6202 (patch)
tree098bb98a9d08b6ec633c00178556bdd9955ce8ae /target/Makefile.in
parent78fa0d4eb4f8ce861664093cb62c1a11b22d90f6 (diff)
Create a common BR2_COPYTO to prepare to replace
all the different COPYTOs spread out all over Buildroot. Generate COPY_FILE subroutine which can be used to copy a file. $(COPY_FILE , file, directory, filename) This will copy to binary dir and to the selected copy dir if set in new config (intended to replace all old COPYTO configs) This is overridden by BUILDROOT_COPYTO, if set into the environment.
Diffstat (limited to 'target/Makefile.in')
-rw-r--r--target/Makefile.in50
1 files changed, 50 insertions, 0 deletions
diff --git a/target/Makefile.in b/target/Makefile.in
index d5d761346..0831c8f03 100644
--- a/target/Makefile.in
+++ b/target/Makefile.in
@@ -3,6 +3,56 @@ BR2_PACKAGE_LINUX_FORMAT:=$(strip $(subst ",,$(BR2_PACKAGE_LINUX_FORMAT)))
BR2_PACKAGE_LINUX_KCONFIG:=$(strip $(subst ",,$(BR2_PACKAGE_LINUX_KCONFIG)))
#"))
+
+# COPY_FILE absolute_path_to_file, target_directory, filename
+ifneq ($(strip $(subst ",,$(BUILDROOT_COPYTO))),) # Use shell definition
+#"))
+define COPY_FILE
+ @echo "BUILDROOT_COPYTO: Copy to $(BUILDROOT_COPYTO)/$(strip $(3))" ; \
+ mkdir -p $(BINARIES_DIR) || echo "Could not create $(BINARIES_DIR)" ; \
+ if [ -w $(BINARIES_DIR) -o -w $(BINARIES_DIR) ] ; then \
+ cp $(1) $(BINARIES_DIR)/$(strip $(3)) || echo "Could not copy $(3)" ; \
+ fi ; \
+ mkdir -p $(BUILDROOT_COPYTO) || echo "Could not create $(BUILDROOT_COPYTO)" ; \
+ if [ -d $(BUILDROOT_COPYTO) -o -w $(BUILDROOT_COPYTO) ] ; then \
+ cp $(1) $(BUILDROOT_COPYTO)/$(strip $(3)) || echo "Could not copy $(3)" ; \
+ fi
+endef
+COPYTO=$(strip $(subst ",,$(BUILDROOT_COPYTO)))
+else ifneq ($(strip $(subst ",,$(BR2_COPYTO))),) # Global override
+#"))
+define COPY_FILE
+ @echo "BR2_COPYTO: Copy to $(BR2_COPYTO)/$(strip $(3))" ; \
+ mkdir -p $(BINARIES_DIR) || echo "Could not create $(BINARIES_DIR)" ; \
+ if [ -w $(BINARIES_DIR) -o -w $(BINARIES_DIR) ] ; then \
+ cp $(1) $(BINARIES_DIR)/$(strip $(3)) || echo "Could not copy $(3)" ; \
+ fi ; \
+ if [ "$(strip $(subst ",,$(BR2_COPYTO)))X" != "X" ] ; then \
+ mkdir -p $(BR2_COPYTO) || echo "Could not create $(BR2_COPYTO)" ; \
+ if [ -d $(BR2_COPYTO) -o -w $(BR2_COPYTO) ] ; then \
+ cp $(1) $(BR2_COPYTO)/$(strip $(3)) || echo "Could not copy $(3)" ; \
+ fi ; \
+ fi
+endef
+#"))
+COPYTO=$(strip $(subst ",,$(BR2_COPYTO)))
+else # Package specific copyto, or empty
+define COPY_FILE
+ @echo "Copy to $(2)/$(strip $(3))" ; \
+ mkdir -p $(BINARIES_DIR) || echo "Could not create $(BINARIES_DIR)" ; \
+ if [ -w $(BINARIES_DIR) -o -w $(BINARIES_DIR) ] ; then \
+ cp $(1) $(BINARIES_DIR)/$(strip $(3)) || echo "Could not copy $(3)" ; \
+ fi ; \
+ if [ "$(strip $(subst ",,$(2)))X" != "X" ] ; then \
+ mkdir -p $(2) || echo "Could not create $(2)" ; \
+ if [ -d $(2) -o -w $(2) ] ; then \
+ cp $(1) $(2)/$(strip $(3)) || echo "Could not copy $(3)" ; \
+ fi ; \
+ fi
+endef
+#"))
+endif
+
# make sure to put everything that is board-specific before the tarroot targets
include target/generic/Makefile.in