summaryrefslogtreecommitdiff
path: root/target/Makefile.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-07-30 17:35:13 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-09-05 14:43:17 +0200
commit79c213fbe5aa188e60563b88708e267cfe5bf4ec (patch)
tree1fbaf847e0ae431d0156fd5b4e69543b463cdbe9 /target/Makefile.in
parent5c4555d1f54f4ede48729f78119d12b696f72d76 (diff)
target: use qstrip
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'target/Makefile.in')
-rw-r--r--target/Makefile.in22
1 files changed, 8 insertions, 14 deletions
diff --git a/target/Makefile.in b/target/Makefile.in
index a835353e4..df980b473 100644
--- a/target/Makefile.in
+++ b/target/Makefile.in
@@ -1,12 +1,9 @@
-BR2_PACKAGE_LINUX_FORMAT:=$(strip $(subst ",,$(BR2_PACKAGE_LINUX_FORMAT)))
-#"))
-BR2_PACKAGE_LINUX_KCONFIG:=$(strip $(subst ",,$(BR2_PACKAGE_LINUX_KCONFIG)))
-#"))
+BR2_PACKAGE_LINUX_FORMAT:=$(call qstrip,$(BR2_PACKAGE_LINUX_FORMAT))
+BR2_PACKAGE_LINUX_KCONFIG:=$(call qstrip,$(BR2_PACKAGE_LINUX_KCONFIG))
# COPY_FILE absolute_path_to_file, target_directory, filename
-ifneq ($(strip $(subst ",,$(BUILDROOT_COPYTO))),) # Use shell definition
-#"))
+ifneq ($(call qstrip,$(BUILDROOT_COPYTO)),) # Use shell definition
define COPY_FILE
@echo "BUILDROOT_COPYTO: Copy to $(BUILDROOT_COPYTO)/$(strip $(3))" ; \
mkdir -p $(BINARIES_DIR) || echo "Could not create $(BINARIES_DIR)" ; \
@@ -18,25 +15,23 @@ define COPY_FILE
cp $(1) $(BUILDROOT_COPYTO)/$(strip $(3)) || echo "Could not copy $(3)" ; \
fi
endef
-COPYTO=$(strip $(subst ",,$(BUILDROOT_COPYTO)))
+COPYTO=$(call qstrip,$(BUILDROOT_COPYTO))
else
-ifneq ($(strip $(subst ",,$(BR2_COPYTO))),) # Global override
-#"))
+ifneq ($(call qstrip,$(BR2_COPYTO)),) # Global override
define COPY_FILE
@echo "BR2_COPYTO: Copy to $(BR2_COPYTO)/$(strip $(3))" ; \
mkdir -p $(BINARIES_DIR) || echo "Could not create $(BINARIES_DIR)" ; \
if [ -w $(BINARIES_DIR) -o -w $(BINARIES_DIR) ] ; then \
cp $(1) $(BINARIES_DIR)/$(strip $(3)) || echo "Could not copy $(3)" ; \
fi ; \
- if [ "$(strip $(subst ",,$(BR2_COPYTO)))X" != "X" ] ; then \
+ if [ "$(call qstrip,$(BR2_COPYTO))X" != "X" ] ; then \
mkdir -p $(BR2_COPYTO) || echo "Could not create $(BR2_COPYTO)" ; \
if [ -d $(BR2_COPYTO) -o -w $(BR2_COPYTO) ] ; then \
cp $(1) $(BR2_COPYTO)/$(strip $(3)) || echo "Could not copy $(3)" ; \
fi ; \
fi
endef
-#"))
-COPYTO=$(strip $(subst ",,$(BR2_COPYTO)))
+COPYTO=$(call qstrip,$(BR2_COPYTO))
else # Package specific copyto, or empty
define COPY_FILE
@echo "Copy to $(2)/$(strip $(3))" ; \
@@ -44,14 +39,13 @@ define COPY_FILE
if [ -w $(BINARIES_DIR) -o -w $(BINARIES_DIR) ] ; then \
cp $(1) $(BINARIES_DIR)/$(strip $(3)) || echo "Could not copy $(3)" ; \
fi ; \
- if [ "$(strip $(subst ",,$(2)))X" != "X" ] ; then \
+ if [ "$(call qstrip,$(2))X" != "X" ] ; then \
mkdir -p $(2) || echo "Could not create $(2)" ; \
if [ -d $(2) -o -w $(2) ] ; then \
cp $(1) $(2)/$(strip $(3)) || echo "Could not copy $(3)" ; \
fi ; \
fi
endef
-#"))
endif
endif