summaryrefslogtreecommitdiff
path: root/target/Makefile.in
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-12 17:42:18 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-12 17:42:18 +0000
commitde7ae0beedd19eb9f2bf696d2b71dde5771afc2a (patch)
treefce75694b7763527703e3ed62609521d4dd46932 /target/Makefile.in
parent6e53512a7d86929330456c29d5e954a39ade906f (diff)
- revert incorrect parts from sjhill's r17800 and add some more documentation.
Now the kernel as well as /lib/modules are properly included in the final tarball and all other tarroot/genfs targets.
Diffstat (limited to 'target/Makefile.in')
-rw-r--r--target/Makefile.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/Makefile.in b/target/Makefile.in
index 7ec139db9..d00442d10 100644
--- a/target/Makefile.in
+++ b/target/Makefile.in
@@ -1,13 +1,15 @@
# make sure to put everything that is board-specific before the tarroot targets
include target/generic/Makefile.in
+
+# this eventually adds the kernel target to TARGETS:
include target/device/Makefile.in
include target/x86/Makefile.in
include target/arm/Makefile.in
include target/powerpc/Makefile.in
# and finally build the filesystems/tarballs
include target/*/*.mk
+
# kernel rules
-ifeq ($(BR2_PACKAGE_LINUX),y)
-TARGETS+=linux26
-endif
+# We already did add the kernel target to TARGETS and now just pull in the rules
+# to actually build this target.
include target/linux*.mk