summaryrefslogtreecommitdiff
path: root/target/cpio
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-10 22:30:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:36 +0200
commit0585241505cfaddc9db6ae92739bdfb5ce5f9794 (patch)
tree8fb56f7d4ba91b0384e522c10ed9dbdb77dfe7ec /target/cpio
parent325bfd1cbae03fe286796d3fa7de7c0a3227f7a5 (diff)
Move all filesystem generation code to fs/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'target/cpio')
-rw-r--r--target/cpio/Config.in40
-rw-r--r--target/cpio/cpioroot.mk18
2 files changed, 0 insertions, 58 deletions
diff --git a/target/cpio/Config.in b/target/cpio/Config.in
deleted file mode 100644
index 02fd00d34..000000000
--- a/target/cpio/Config.in
+++ /dev/null
@@ -1,40 +0,0 @@
-config BR2_TARGET_ROOTFS_CPIO
- bool "cpio the root filesystem"
- help
- Build a cpio archive of the root filesystem
-
-choice
- prompt "Compression method"
- default BR2_TARGET_ROOTFS_CPIO_NONE
- depends on BR2_TARGET_ROOTFS_CPIO
- help
- Select compressor for cpio filesystem of the root filesystem
-
-config BR2_TARGET_ROOTFS_CPIO_NONE
- bool "no compression"
- help
- Do not compress the cpio filesystem.
-
-config BR2_TARGET_ROOTFS_CPIO_GZIP
- bool "gzip"
- help
- Do compress the cpio filesystem with gzip.
- Note that you either have to have gzip installed on your host
- or select to build a gzip for your host. See the packages submenu.
-
-config BR2_TARGET_ROOTFS_CPIO_BZIP2
- bool "bzip2"
- help
- Do compress the cpio filesystem with bzip2.
- Note that you either have to have bzip2 installed on your host
- or select to build a bzip2 for your host. See the packages submenu.
-
-config BR2_TARGET_ROOTFS_CPIO_LZMA
- bool "lzma"
- help
- Do compress the cpio filesystem with lzma.
- Note that you either have to have lzma installed on your host
- or select to build a lzma for your host. See the packages submenu.
-
-endchoice
-
diff --git a/target/cpio/cpioroot.mk b/target/cpio/cpioroot.mk
deleted file mode 100644
index ab7d54618..000000000
--- a/target/cpio/cpioroot.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#############################################################
-#
-# cpio to archive target filesystem
-#
-#############################################################
-
-define ROOTFS_CPIO_INIT_SYMLINK
- rm -f $(TARGET_DIR)/init
- ln -s sbin/init $(TARGET_DIR)/init
-endef
-
-ROOTFS_CPIO_PRE_GEN_HOOKS += ROOTFS_CPIO_INIT_SYMLINK
-
-define ROOTFS_CPIO_CMD
- cd $(TARGET_DIR) && find . | cpio --quiet -o -H newc > $$@
-endef
-
-$(eval $(call ROOTFS_TARGET,cpio)) \ No newline at end of file