summaryrefslogtreecommitdiff
path: root/target/cramfs
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-21 14:32:38 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-21 14:32:38 +0000
commit1afb8226cbaf011f81158b63c2c169ce05842d21 (patch)
treee98b0ceb30d7dc264513db121b16dab45282c9a3 /target/cramfs
parent3cca2a310d5e6a793784c9c5c28076f161713077 (diff)
- start to use BR2_HAVE_MANPAGES and BR2_HAVE_INFOPAGES
- always error out if ldconfig for the target fails (was inconsistent..)
Diffstat (limited to 'target/cramfs')
-rw-r--r--target/cramfs/cramfs.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/cramfs/cramfs.mk b/target/cramfs/cramfs.mk
index 2af85a6a9..3acc86a81 100644
--- a/target/cramfs/cramfs.mk
+++ b/target/cramfs/cramfs.mk
@@ -50,9 +50,13 @@ CRAMFS_TARGET=$(IMAGE).cramfs
cramfsroot: host-fakeroot makedevs cramfs
#-@find $(TARGET_DIR)/lib -type f -name \*.so\* | xargs $(STRIP) --strip-unneeded 2>/dev/null || true;
-@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
+ifneq ($(BR2_HAVE_MANPAGES),y)
@rm -rf $(TARGET_DIR)/usr/man
+endif
+ifneq ($(BR2_HAVE_INFOPAGES),y)
@rm -rf $(TARGET_DIR)/usr/info
- -$(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null
+endif
+ $(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null
# Use fakeroot to pretend all target binaries are owned by root
rm -f $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
touch $(PROJECT_BUILD_DIR)/.fakeroot.00000