summaryrefslogtreecommitdiff
path: root/target/cramfs
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-03-20 16:52:44 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-03-20 16:52:44 +0000
commitf94a44c3ad06ae6bab203a3dda314b9ed98785e0 (patch)
treecf38157262febf2af1fac1bdd7489a7d5635396f /target/cramfs
parent0e59ed02089d4c337c1ab2edcc62672ca51425f9 (diff)
- use numeric values for the superuser to be more portable.
Closes #1250
Diffstat (limited to 'target/cramfs')
-rw-r--r--target/cramfs/cramfs.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/cramfs/cramfs.mk b/target/cramfs/cramfs.mk
index 0f488e143..54a0fa845 100644
--- a/target/cramfs/cramfs.mk
+++ b/target/cramfs/cramfs.mk
@@ -71,7 +71,7 @@ cramfsroot: host-fakeroot makedevs cramfs
rm -f $(STAGING_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
touch $(STAGING_DIR)/.fakeroot.00000
cat $(STAGING_DIR)/.fakeroot* > $(STAGING_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
- echo "chown -R root:root $(TARGET_DIR)" >> $(STAGING_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
+ echo "chown -R 0:0 $(TARGET_DIR)" >> $(STAGING_DIR)/_fakeroot.$(notdir $(CRAMFS_TARGET))
ifneq ($(TARGET_DEVICE_TABLE),)
# Use fakeroot to pretend to create all needed device nodes
echo "$(STAGING_DIR)/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \