summaryrefslogtreecommitdiff
path: root/target/device/AMD
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-03-10 19:47:57 +0000
committerEric Andersen <andersen@codepoet.org>2005-03-10 19:47:57 +0000
commit781ce9185d69dfb39a917415ece8bd28c507116e (patch)
treeec4189d5a605424957d5da7437bf3041f9d35a86 /target/device/AMD
parentdccecf52b00eb3aa941b3111d41f60689088003b (diff)
The DBAu1500 can run as either big or little endian
Diffstat (limited to 'target/device/AMD')
-rw-r--r--target/device/AMD/Config.in2
-rw-r--r--target/device/AMD/DBAu1500/Makefile.in2
-rw-r--r--target/device/AMD/DBAu1500/uClibc.config.mips157
-rw-r--r--target/device/AMD/DBAu1500/uClibc.config.mipsel (renamed from target/device/AMD/DBAu1500/uClibc.config)0
4 files changed, 159 insertions, 2 deletions
diff --git a/target/device/AMD/Config.in b/target/device/AMD/Config.in
index 6e31eb52d..5d5cc29ed 100644
--- a/target/device/AMD/Config.in
+++ b/target/device/AMD/Config.in
@@ -2,7 +2,7 @@ comment "AMD Specific Device Support"
config BR2_TARGET_AMD_ALCHEMY
bool "Board support for the AMD development boards"
- depends BR2_mipsel
+ depends BR2_mipsel || BR2_mips
default n
help
AMD Alchemy mips based systems
diff --git a/target/device/AMD/DBAu1500/Makefile.in b/target/device/AMD/DBAu1500/Makefile.in
index 4bfca42b5..675034df9 100644
--- a/target/device/AMD/DBAu1500/Makefile.in
+++ b/target/device/AMD/DBAu1500/Makefile.in
@@ -1,7 +1,7 @@
ALCHEMY_DBAU1500_PATH=target/device/AMD/DBAu1500
BUSYBOX_CONFIG=$(ALCHEMY_DBAU1500_PATH)/busybox.config
-UCLIBC_CONFIG_FILE=$(ALCHEMY_DBAU1500_PATH)/uClibc.config
+UCLIBC_CONFIG_FILE=$(ALCHEMY_DBAU1500_PATH)/uClibc.config.$(ARCH)
TARGET_SKELETON=$(ALCHEMY_DBAU1500_PATH)/skel.tar.gz
TARGET_SKEL_DIR=$(ALCHEMY_DBAU1500_PATH)/target_skeleton
diff --git a/target/device/AMD/DBAu1500/uClibc.config.mips b/target/device/AMD/DBAu1500/uClibc.config.mips
new file mode 100644
index 000000000..e4aa771b5
--- /dev/null
+++ b/target/device/AMD/DBAu1500/uClibc.config.mips
@@ -0,0 +1,157 @@
+#
+# Automatically generated make config: don't edit
+#
+# TARGET_alpha is not set
+# TARGET_arm is not set
+# TARGET_bfin is not set
+# TARGET_cris is not set
+# TARGET_e1 is not set
+# TARGET_frv is not set
+# TARGET_h8300 is not set
+# TARGET_i386 is not set
+# TARGET_i960 is not set
+# TARGET_m68k is not set
+# TARGET_microblaze is not set
+TARGET_mips=y
+# TARGET_nios is not set
+# TARGET_nios2 is not set
+# TARGET_powerpc is not set
+# TARGET_sh is not set
+# TARGET_sparc is not set
+# TARGET_v850 is not set
+# TARGET_x86_64 is not set
+
+#
+# Target Architecture Features and Options
+#
+HAVE_ELF=y
+ARCH_SUPPORTS_LITTLE_ENDIAN=y
+TARGET_ARCH="mips"
+ARCH_CFLAGS="-mno-split-addresses"
+ARCH_SUPPORTS_BIG_ENDIAN=y
+# CONFIG_MIPS_ISA_1 is not set
+# CONFIG_MIPS_ISA_2 is not set
+CONFIG_MIPS_ISA_3=y
+# CONFIG_MIPS_ISA_4 is not set
+# CONFIG_MIPS_ISA_MIPS32 is not set
+# CONFIG_MIPS_ISA_MIPS64 is not set
+# ARCH_LITTLE_ENDIAN is not set
+ARCH_BIG_ENDIAN=y
+# ARCH_HAS_NO_MMU is not set
+ARCH_HAS_MMU=y
+UCLIBC_HAS_FLOATS=y
+HAS_FPU=y
+DO_C99_MATH=y
+WARNINGS="-Wall"
+KERNEL_SOURCE="/usr/src/linux"
+C_SYMBOL_PREFIX=""
+HAVE_DOT_CONFIG=y
+
+#
+# General Library Settings
+#
+# HAVE_NO_PIC is not set
+DOPIC=y
+# HAVE_NO_SHARED is not set
+HAVE_SHARED=y
+# ARCH_HAS_NO_LDSO is not set
+BUILD_UCLIBC_LDSO=y
+# FORCE_SHAREABLE_TEXT_SEGMENTS is not set
+LDSO_LDD_SUPPORT=y
+LDSO_CACHE_SUPPORT=y
+# LDSO_PRELOAD_FILE_SUPPORT is not set
+LDSO_BASE_FILENAME="ld.so"
+UCLIBC_CTOR_DTOR=y
+# HAS_NO_THREADS is not set
+UCLIBC_HAS_THREADS=y
+PTHREADS_DEBUG_SUPPORT=y
+UCLIBC_HAS_LFS=y
+# UCLIBC_STATIC_LDCONFIG is not set
+# MALLOC is not set
+# MALLOC_SIMPLE is not set
+MALLOC_STANDARD=y
+MALLOC_GLIBC_COMPAT=y
+UCLIBC_DYNAMIC_ATEXIT=y
+HAS_SHADOW=y
+# UNIX98PTY_ONLY is not set
+ASSUME_DEVPTS=y
+UCLIBC_HAS_TM_EXTENSIONS=y
+UCLIBC_HAS_TZ_CACHING=y
+UCLIBC_HAS_TZ_FILE=y
+UCLIBC_HAS_TZ_FILE_READ_MANY=y
+UCLIBC_TZ_FILE_PATH="/etc/TZ"
+
+#
+# Networking Support
+#
+UCLIBC_HAS_IPV6=y
+UCLIBC_HAS_RPC=y
+UCLIBC_HAS_FULL_RPC=y
+
+#
+# String and Stdio Support
+#
+UCLIBC_HAS_STRING_GENERIC_OPT=y
+UCLIBC_HAS_STRING_ARCH_OPT=y
+UCLIBC_HAS_CTYPE_TABLES=y
+UCLIBC_HAS_CTYPE_SIGNED=y
+# UCLIBC_HAS_CTYPE_UNSAFE is not set
+UCLIBC_HAS_CTYPE_CHECKED=y
+# UCLIBC_HAS_CTYPE_ENFORCED is not set
+UCLIBC_HAS_WCHAR=y
+# UCLIBC_HAS_LOCALE is not set
+UCLIBC_HAS_HEXADECIMAL_FLOATS=y
+UCLIBC_HAS_GLIBC_CUSTOM_PRINTF=y
+UCLIBC_PRINTF_SCANF_POSITIONAL_ARGS=9
+UCLIBC_HAS_SCANF_GLIBC_A_FLAG=y
+# UCLIBC_HAS_STDIO_BUFSIZ_NONE is not set
+# UCLIBC_HAS_STDIO_BUFSIZ_256 is not set
+# UCLIBC_HAS_STDIO_BUFSIZ_512 is not set
+# UCLIBC_HAS_STDIO_BUFSIZ_1024 is not set
+# UCLIBC_HAS_STDIO_BUFSIZ_2048 is not set
+UCLIBC_HAS_STDIO_BUFSIZ_4096=y
+# UCLIBC_HAS_STDIO_BUFSIZ_8192 is not set
+UCLIBC_HAS_STDIO_BUILTIN_BUFFER_NONE=y
+# UCLIBC_HAS_STDIO_BUILTIN_BUFFER_4 is not set
+# UCLIBC_HAS_STDIO_BUILTIN_BUFFER_8 is not set
+UCLIBC_HAS_STDIO_GETC_MACRO=y
+UCLIBC_HAS_STDIO_PUTC_MACRO=y
+UCLIBC_HAS_STDIO_AUTO_RW_TRANSITION=y
+# UCLIBC_HAS_FOPEN_LARGEFILE_MODE is not set
+UCLIBC_HAS_FOPEN_EXCLUSIVE_MODE=y
+UCLIBC_HAS_GLIBC_CUSTOM_STREAMS=y
+UCLIBC_HAS_PRINTF_M_SPEC=y
+UCLIBC_HAS_ERRNO_MESSAGES=y
+# UCLIBC_HAS_SYS_ERRLIST is not set
+UCLIBC_HAS_SIGNUM_MESSAGES=y
+# UCLIBC_HAS_SYS_SIGLIST is not set
+UCLIBC_HAS_GNU_GETOPT=y
+
+#
+# Big and Tall
+#
+UCLIBC_HAS_REGEX=y
+# UCLIBC_HAS_WORDEXP is not set
+UCLIBC_HAS_FTW=y
+UCLIBC_HAS_GLOB=y
+
+#
+# Library Installation Options
+#
+SHARED_LIB_LOADER_PREFIX="/lib"
+RUNTIME_PREFIX="/"
+DEVEL_PREFIX="/usr/"
+
+#
+# uClibc security related options
+#
+# UCLIBC_SECURITY is not set
+
+#
+# uClibc development/debugging options
+#
+# DODEBUG is not set
+# DOASSERTS is not set
+# SUPPORT_LD_DEBUG is not set
+# SUPPORT_LD_DEBUG_EARLY is not set
+# UCLIBC_MJN3_ONLY is not set
diff --git a/target/device/AMD/DBAu1500/uClibc.config b/target/device/AMD/DBAu1500/uClibc.config.mipsel
index 7054c3dbc..7054c3dbc 100644
--- a/target/device/AMD/DBAu1500/uClibc.config
+++ b/target/device/AMD/DBAu1500/uClibc.config.mipsel