summaryrefslogtreecommitdiff
path: root/target/device/Atmel/Makefile.in
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-26 23:52:31 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-26 23:52:31 +0000
commit0dbf9dd7ab8e08e9081a1141f0122f0e2cdc6202 (patch)
tree098bb98a9d08b6ec633c00178556bdd9955ce8ae /target/device/Atmel/Makefile.in
parent78fa0d4eb4f8ce861664093cb62c1a11b22d90f6 (diff)
Create a common BR2_COPYTO to prepare to replace
all the different COPYTOs spread out all over Buildroot. Generate COPY_FILE subroutine which can be used to copy a file. $(COPY_FILE , file, directory, filename) This will copy to binary dir and to the selected copy dir if set in new config (intended to replace all old COPYTO configs) This is overridden by BUILDROOT_COPYTO, if set into the environment.
Diffstat (limited to 'target/device/Atmel/Makefile.in')
-rw-r--r--target/device/Atmel/Makefile.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/device/Atmel/Makefile.in b/target/device/Atmel/Makefile.in
index b6ca1be1a..fd53e6ee9 100644
--- a/target/device/Atmel/Makefile.in
+++ b/target/device/Atmel/Makefile.in
@@ -13,7 +13,11 @@ TARGET_SKELETON:=$(ATMEL_TARGET)/target_skeleton
TARGET_DEVICE_TABLE:=$(ATMEL_TARGET)/device_table.txt
TARGET_SKELETON_LINKS:=$(ATMEL_TARGET)/skel.tar.gz
+ifneq ($(COPYTO),)
+TARGET_ATMEL_COPYTO:=$(strip $(subst ",, $(BR2_COPYTO)))
+else
TARGET_ATMEL_COPYTO:=$(strip $(subst ",, $(BR2_TARGET_ATMEL_COPYTO)))
+endif
# These are set by Config.in
DOWNLOAD_LINUX26_VERSION:= $(strip $(subst ",, $(BR2_DOWNLOAD_LINUX26_VERSION)))