summaryrefslogtreecommitdiff
path: root/target/device/mips/Makefile.in
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-22 08:47:09 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-06-22 08:47:09 +0000
commit4a175d23197948c6cd5e9870e66fb636c5daeb35 (patch)
tree950cb8a022e636bbb6f7d3b490dd96c1634de1e3 /target/device/mips/Makefile.in
parent0848d01d385b9043c0994d146382c9c96f64209e (diff)
- add a sample (pseudo-)board for a mips malta box
Diffstat (limited to 'target/device/mips/Makefile.in')
-rw-r--r--target/device/mips/Makefile.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/device/mips/Makefile.in b/target/device/mips/Makefile.in
new file mode 100644
index 000000000..af8cf65ca
--- /dev/null
+++ b/target/device/mips/Makefile.in
@@ -0,0 +1,22 @@
+BR2_BOARD_PATH:=target/device/mips
+
+ifeq ($(strip $(BR2_PACKAGE_LINUX_KCONFIG)),)
+ifndef LINUX26_KCONFIG
+LINUX26_KCONFIG=$(BR2_BOARD_PATH)/linux26.config
+endif
+else
+LINUX26_KCONFIG=$(strip $(BR2_PACKAGE_LINUX_KCONFIG))
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_LINUX_FORMAT)),)
+ifndef LINUX26_FORMAT
+LINUX26_FORMAT=vmlinux
+endif
+else
+LINUX26_FORMAT=$(strip $(BR2_PACKAGE_LINUX_FORMAT))
+endif
+
+ifndef LINUX26_BINLOC
+# mips32 has the vmlinux in the toplevel kernel build-tree.
+LINUX26_BINLOC=$(LINUX26_FORMAT)
+endif