summaryrefslogtreecommitdiff
path: root/target/device/xtensa
diff options
context:
space:
mode:
authorMaxim Grigoriev <maxim2405@gmail.com>2009-07-24 02:17:22 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-07-24 02:17:22 +0200
commit5ddb904a8620bceddd4df1c05c7342e10592c0c3 (patch)
tree0e01403aa2e63e0f36922cd10bda0cb31f4f6952 /target/device/xtensa
parentcd0b1ce3b7934c631477ad3262316199b73cce89 (diff)
target/; xtensa support
Part of #163. Signed-off-by: Maxim Grigoriev <maxim2405@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'target/device/xtensa')
-rw-r--r--target/device/xtensa/Config.in21
-rw-r--r--target/device/xtensa/Makefile.in14
-rw-r--r--target/device/xtensa/device_table.diff10
-rw-r--r--target/device/xtensa/skeleton-patch/etc/inittab47
4 files changed, 92 insertions, 0 deletions
diff --git a/target/device/xtensa/Config.in b/target/device/xtensa/Config.in
new file mode 100644
index 000000000..0d4408c23
--- /dev/null
+++ b/target/device/xtensa/Config.in
@@ -0,0 +1,21 @@
+menuconfig BR2_TARGET_XTENSA
+ bool "Device and Board Support for Xtensa and Diamond cores"
+ depends on BR2_xtensa
+ default y
+ help
+ Lists development boards with support for the Xtensa architecture.
+
+if BR2_TARGET_XTENSA
+comment "Tensilica Xtensa/Diamond based Device Support"
+ depends on BR2_xtensa
+
+config BR2_TARGET_XTENSA_XTAV60
+ bool "XTAV60/200 board (Avnet LX60 or LX200 plus Tensilica IP)"
+ depends on BR2_xtensa
+ default y
+ help
+ The XTAV60 or XTAV200 board, which is an Avnet LX60 or LX200
+ emulation board programmed with an FPGA bitstream obtained
+ from Tensilica.
+
+endif
diff --git a/target/device/xtensa/Makefile.in b/target/device/xtensa/Makefile.in
new file mode 100644
index 000000000..f3248962f
--- /dev/null
+++ b/target/device/xtensa/Makefile.in
@@ -0,0 +1,14 @@
+ifeq ($(strip $(BR2_TARGET_XTENSA_XTAV60)),y)
+# UCLIBC_CONFIG_FILE:=target/device/xtensa/xtav60/uClibc.config
+# BR2_PACKAGE_BUSYBOX_CONFIG:=target/device/xtensa/xtav60/busybox.config
+TARGET_SKELETON_PATCH:=target/device/xtensa
+endif
+
+# Custom device table patch used when targeting ISS:
+OLD_TARGET_DEVICE_TABLE := $(TARGET_DEVICE_TABLE)
+TARGET_DEVICE_TABLE := target/device/xtensa/device_table.txt
+makedevs:
+ @echo "Applying patch to $(TARGET_DEVICE_TABLE)"
+ cp -f $(OLD_TARGET_DEVICE_TABLE) $(TARGET_DEVICE_TABLE)
+ patch -p1 -g 0 < target/device/xtensa/device_table.diff
+
diff --git a/target/device/xtensa/device_table.diff b/target/device/xtensa/device_table.diff
new file mode 100644
index 000000000..12f682546
--- /dev/null
+++ b/target/device/xtensa/device_table.diff
@@ -0,0 +1,10 @@
+diff --git a/target/generic/device_table.txt b/target/generic/device_table.txt
+index f4b16ba..b87bf69 100644
+--- a/target/device/xtensa/device_table.txt
++++ b/target/device/xtensa/device_table.txt
+@@ -169,3 +169,5 @@
+ #/dev/mcd b 640 0 0 23 0 0 0
+ #/dev/optcd b 640 0 0 17 0 0 0
+
++/dev/simdisk0 b 640 0 0 240 0 0 0
++/dev/simdisk1 b 640 0 0 240 1 0 0
diff --git a/target/device/xtensa/skeleton-patch/etc/inittab b/target/device/xtensa/skeleton-patch/etc/inittab
new file mode 100644
index 000000000..b336ff69c
--- /dev/null
+++ b/target/device/xtensa/skeleton-patch/etc/inittab
@@ -0,0 +1,47 @@
+# /etc/inittab
+#
+# Copyright (C) 2001 Erik Andersen <andersen@codepoet.org>
+#
+# Note: BusyBox init doesn't support runlevels. The runlevels field is
+# completely ignored by BusyBox init. If you want runlevels, use
+# sysvinit.
+#
+# Format for each entry: <id>:<runlevels>:<action>:<process>
+#
+# id == tty to run on, or empty for /dev/console
+# runlevels == ignored
+# action == one of sysinit, respawn, askfirst, wait, and once
+# process == program to run
+
+# Startup the system
+null::sysinit:/bin/mount -t proc proc /proc
+null::sysinit:/bin/mount -o remount,rw /
+null::sysinit:/bin/mount -a
+null::sysinit:/bin/hostname -F /etc/hostname
+null::sysinit:/sbin/ifconfig lo 127.0.0.1 up
+null::sysinit:/sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo
+# now run any rc scripts
+::sysinit:/etc/init.d/rcS
+
+# Set up a couple of getty's
+#tty1::respawn:/sbin/getty 38400 tty1
+#tty2::respawn:/sbin/getty 38400 tty2
+
+# Put a getty on the serial port
+ttyS0::respawn:/sbin/getty -L ttyS0 38400 vt100
+
+# Logging junk
+null::sysinit:/bin/touch /var/log/messages
+null::respawn:/sbin/syslogd -n -m 0
+null::respawn:/sbin/klogd -n
+#tty3::respawn:/usr/bin/tail -f /var/log/messages
+
+# Stuff to do for the 3-finger salute
+::ctrlaltdel:/sbin/reboot
+
+# Stuff to do before rebooting
+null::shutdown:/usr/bin/killall klogd
+null::shutdown:/usr/bin/killall syslogd
+null::shutdown:/bin/umount -a -r
+null::shutdown:/sbin/swapoff -a
+