summaryrefslogtreecommitdiff
path: root/target/device
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-22 08:46:49 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-22 08:46:49 +0000
commit487f8c9d03a62f92b69c22afaa7f6c5082494c72 (patch)
tree0d15db3c52bf8cfdf4892db9f86dad7d8d016f22 /target/device
parent1c299aa38f18a7c2e459caa8073bd6003fad31c0 (diff)
fixup kernel compile
Diffstat (limited to 'target/device')
-rw-r--r--target/device/Soekris/Makefile.in6
-rw-r--r--target/device/Soekris/net4521/linux.mk10
2 files changed, 6 insertions, 10 deletions
diff --git a/target/device/Soekris/Makefile.in b/target/device/Soekris/Makefile.in
index 5a00e9b0f..4aaf1ef8e 100644
--- a/target/device/Soekris/Makefile.in
+++ b/target/device/Soekris/Makefile.in
@@ -3,3 +3,9 @@ ifeq ($(strip $(BR2_TARGET_SOEKRIS_NET4521)),y)
UCLIBC_CONFIG_FILE:=target/device/Soekris/net4521/uClibc.config
BUSYBOX_CONFIG:=target/device/Soekris/net4521/busybox.config
endif
+
+ifeq ($(strip $(BR2_PACKAGE_LINUX)),y)
+include target/device/Soekris/net4521/linux.mk
+TARGETS+=linux
+endif
+
diff --git a/target/device/Soekris/net4521/linux.mk b/target/device/Soekris/net4521/linux.mk
index 2d29a6a3e..a081eec4c 100644
--- a/target/device/Soekris/net4521/linux.mk
+++ b/target/device/Soekris/net4521/linux.mk
@@ -19,7 +19,6 @@
# -Erik
#
#############################################################
-ifneq ($(filter $(TARGETS),linux),)
# Version of Linux to download and then apply patches to
DOWNLOAD_LINUX_VERSION=2.4.29
@@ -110,12 +109,3 @@ linuxclean: clean
linux-dirclean:
rm -rf $(LINUX_DIR)
-endif
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(strip $(BR2_PACKAGE_LINUX)),y)
-TARGETS+=linux
-endif