summaryrefslogtreecommitdiff
path: root/target/ext2/ext2root.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-08-08 06:57:43 +0000
committerEric Andersen <andersen@codepoet.org>2005-08-08 06:57:43 +0000
commit06c5ff4e823cab16987d89c585ef2de4a3db2a7b (patch)
tree7c112f6202f48b15e550f602a0e750c7205eb421 /target/ext2/ext2root.mk
parentab3bf08f9c3009364da713bbda03902b9cc06d3b (diff)
minor cleanup for target handling
Diffstat (limited to 'target/ext2/ext2root.mk')
-rw-r--r--target/ext2/ext2root.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/target/ext2/ext2root.mk b/target/ext2/ext2root.mk
index 49b2e076f..5f5bdb1eb 100644
--- a/target/ext2/ext2root.mk
+++ b/target/ext2/ext2root.mk
@@ -70,11 +70,9 @@ $(EXT2_BASE): host-fakeroot makedevs genext2fs
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/share/man
@rm -rf $(TARGET_DIR)/usr/info
- test -e "$(TARGET_DIR)/etc/ld.so.conf" \
- && /sbin/ldconfig -r $(TARGET_DIR) \
- || true
+ -/sbin/ldconfig -r $(TARGET_DIR) 2>/dev/null
# Use fakeroot to pretend all target binaries are owned by root
- $(STAGING_DIR)/usr/bin/fakeroot \
+ -$(STAGING_DIR)/usr/bin/fakeroot \
-i $(STAGING_DIR)/fakeroot.env \
-s $(STAGING_DIR)/fakeroot.env -- \
chown -R root:root $(TARGET_DIR)