summaryrefslogtreecommitdiff
path: root/target/generic/Makefile.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-20 21:59:43 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-20 21:59:43 +0000
commit9611fd600bbc2e6458c3a7bad1ca651b34940cc6 (patch)
tree1eab9fc055e2cf152beab5997a9cb584363f7814 /target/generic/Makefile.in
parentbf1ccf16a25a4ef07ab4862e3e94446b2c372386 (diff)
target/generic: add kconfig for serial getty config (port + baudrate)
These are the settings people most often want to tweak for embedded boards, so add kconfig variables to make it easy to do.
Diffstat (limited to 'target/generic/Makefile.in')
-rw-r--r--target/generic/Makefile.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/generic/Makefile.in b/target/generic/Makefile.in
index 4ea0b6a6b..3541264c8 100644
--- a/target/generic/Makefile.in
+++ b/target/generic/Makefile.in
@@ -7,3 +7,15 @@ TARGET_SKELETON=target/generic/target_busybox_skeleton
TARGET_DEVICE_TABLE=target/generic/mini_device_table.txt
endif
+TARGET_GENERIC_GETTY:=$(strip $(subst ",, $(BR2_TARGET_GENERIC_GETTY_PORT)))
+#"))
+TARGET_GENERIC_GETTY_BAUDRATE:=$(strip $(subst ",, $(BR2_TARGET_GENERIC_GETTY_BAUDRATE)))
+#"))
+
+target-generic-getty:
+ $(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(TARGET_GENERIC_GETTY)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
+ $(TARGET_DIR)/etc/inittab
+
+ifeq ($(BR2_TARGET_GENERIC_GETTY),y)
+TARGETS += target-generic-getty
+endif