summaryrefslogtreecommitdiff
path: root/target/generic
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-10-06 15:08:55 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-06 15:08:55 +0200
commitd31c7723ae05b82f501bac1c69bc91a5162edca6 (patch)
tree01187e7ea46d10d9335046be844d8cd0e279490b /target/generic
parentb1ba675c85c717e376103f07fe9dba8abc380089 (diff)
target/generic: /etc/{hostname,issue}: work around quotes in kconfig
Otherwise the targets will always run. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'target/generic')
-rw-r--r--target/generic/Makefile.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/generic/Makefile.in b/target/generic/Makefile.in
index 31f4a0c3b..f77f9698c 100644
--- a/target/generic/Makefile.in
+++ b/target/generic/Makefile.in
@@ -7,6 +7,8 @@ TARGET_SKELETON=target/generic/target_busybox_skeleton
TARGET_DEVICE_TABLE=target/generic/mini_device_table.txt
endif
+TARGET_GENERIC_HOSTNAME:=$(call qstrip,$(BR2_TARGET_GENERIC_HOSTNAME))
+TARGET_GENERIC_ISSUE:=$(call qstrip,$(BR2_TARGET_GENERIC_ISSUE))
TARGET_GENERIC_GETTY:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT))
TARGET_GENERIC_GETTY_BAUDRATE:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_BAUDRATE))
@@ -22,11 +24,11 @@ target-generic-getty:
$(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(TARGET_GENERIC_GETTY)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
$(TARGET_DIR)/etc/inittab
-ifneq ($(BR2_TARGET_GENERIC_HOSTNAME),)
+ifneq ($(TARGET_GENERIC_HOSTNAME),)
TARGETS += target-generic-hostname
endif
-ifneq ($(BR2_TARGET_GENERIC_ISSUE),)
+ifneq ($(TARGET_GENERIC_ISSUE),)
TARGETS += target-generic-issue
endif