summaryrefslogtreecommitdiff
path: root/target/linux/Makefile.in.advanced
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-05-28 12:03:56 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-28 12:03:56 +0200
commit98de259aee970b70f06f7e98253fbf20419057a0 (patch)
treee18a576c8fd629e075888f6bdcf01f490b5cdc6e /target/linux/Makefile.in.advanced
parent170b3d3d0550b8000cfc0cf789a5a902237353e1 (diff)
linux: zImage target no longer available on x86
The legacy zImage target for x86 was removed from the kernel in 2.6.30, and we state in Config.in that we'll use bzImage if BR2_PACKAGE_LINUX_FORMAT isn't set, so ensure we do so for x86. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'target/linux/Makefile.in.advanced')
-rw-r--r--target/linux/Makefile.in.advanced5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/Makefile.in.advanced b/target/linux/Makefile.in.advanced
index 9e495f3e0..86d94ca40 100644
--- a/target/linux/Makefile.in.advanced
+++ b/target/linux/Makefile.in.advanced
@@ -111,9 +111,14 @@ ifndef LINUX26_FORMAT
ifneq ($(call qstrip,$(BR2_PACKAGE_LINUX_FORMAT)),)
LINUX26_FORMAT:=$(call qstrip,$(BR2_PACKAGE_LINUX_FORMAT))
else
+ifneq ($(filter i386 x86-64,$(KERNEL_ARCH)),)
+# zImage target no longer available on x86 since 2.6.30
+LINUX26_FORMAT=bzImage
+else
LINUX26_FORMAT:=zImage
endif
endif
+endif
# -----------------------------------------------------------------------------
# Has to be set by the target/device