summaryrefslogtreecommitdiff
path: root/target/linux/Makefile.in
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2009-07-22 14:25:05 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-07-22 22:43:51 +0200
commit7bb5ce002cd9ecd697ed4defd912d3f0de02319b (patch)
treeb591d25c6d722eba9503fade34fd1b2283471aa7 /target/linux/Makefile.in
parent8232850c51e07b99ba84769b492faa147290fdc7 (diff)
linux26: do not set CFLAGS_KERNEL to TARGET_CFLAGS
Using TARGET_CFLAGS breaks the kernel build for the arm platform. The result is a kernel that can not be booted. So simply do not fiddle with the CFLAGS on a kernel build and the kernel build system will do the right thing (TM). [Peter: do the same thing for the standard kernel build] Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'target/linux/Makefile.in')
-rw-r--r--target/linux/Makefile.in3
1 files changed, 0 insertions, 3 deletions
diff --git a/target/linux/Makefile.in b/target/linux/Makefile.in
index ff0b88e34..3e8bc7b30 100644
--- a/target/linux/Makefile.in
+++ b/target/linux/Makefile.in
@@ -89,11 +89,8 @@ LINUX26_PATCH_DIR:=$(BOARD_PATH)/kernel-patches/
#"))
endif
endif
-__LINUX26_NO_PIC=-fPIC -fpic -DPIC -fwrapv -ftrapv
-__LINUX26_ZERO_OPTIMIZATION=-O0
LINUX26_MAKE_FLAGS = HOSTCC="$(HOSTCC)" HOSTCFLAGS="$(HOSTCFLAGS)" \
ARCH=$(KERNEL_ARCH) \
- CFLAGS_KERNEL="$(filter-out $(__LINUX26_NO_PIC) $(__LINUX26_ZERO_OPTIMIZATION),$(TARGET_CFLAGS))" \
INSTALL_MOD_PATH=$(TARGET_DIR) \
CROSS_COMPILE=$(KERNEL_CROSS) \
LDFLAGS="$(TARGET_LDFLAGS)" \