summaryrefslogtreecommitdiff
path: root/target/linux
diff options
context:
space:
mode:
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-11-05 12:59:32 +0000
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-11-05 12:59:32 +0000
commit12b5b0124b1c575a28e06a684d74631d85590bf3 (patch)
tree11b19fdeb5a9770269c6f94dddf6c9d58208237c /target/linux
parent7167dedea24cec1c7a2d984e68879cbb2323aa75 (diff)
linux26: make installation of modules rule depend on .depend_done
This patch will make the installation of modules rule depend on .depend_done instead of .configured to make sure make prepare is run before modules are installed. Make kernelversion does not work before make prepare has been run. Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/Makefile.in.advanced2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/Makefile.in.advanced b/target/linux/Makefile.in.advanced
index 38b7c7906..ae4e2ce3e 100644
--- a/target/linux/Makefile.in.advanced
+++ b/target/linux/Makefile.in.advanced
@@ -391,7 +391,7 @@ $(LINUX26_KERNEL): $(LINUX26_DIR)/$(LINUX26_BINLOC)
touch -c $@
# -----------------------------------------------------------------------------
-$(PROJECT_BUILD_DIR)/autotools-stamps/linux_modules_target_installed: $(LINUX26_DIR)/.configured
+$(PROJECT_BUILD_DIR)/autotools-stamps/linux_modules_target_installed: $(LINUX26_DIR)/.depend_done
rm -rf $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION_PROBED)
rm -f $(TARGET_DIR)/sbin/cardmgr
# Make Linux depend on modules only if enabled in the .config.