summaryrefslogtreecommitdiff
path: root/target/linux
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-25 23:14:55 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-25 23:14:55 +0000
commit147b034d0dd429c7cbcbb4462217fbdd01608b00 (patch)
tree1c0deb732b487cabf94ed4a10c6055d0a2cced28 /target/linux
parent070de4f146d83884c21b8698ca5a43a0b2de0f45 (diff)
Ensure /boot exists, Write linux version to file,in case the kernel version has changed after the first build
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/Makefile.in.advanced2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/Makefile.in.advanced b/target/linux/Makefile.in.advanced
index 4c9857a48..9f9a45180 100644
--- a/target/linux/Makefile.in.advanced
+++ b/target/linux/Makefile.in.advanced
@@ -227,6 +227,7 @@ $(LINUX26_DIR)/.unpacked: $(DL_DIR)/$(LINUX26_SOURCE)
ifneq ($(DOWNLOAD_LINUX26_VERSION),$(LINUX26_VERSION))
# Rename the dir from the downloaded version to the AFTER patch version
mv -f $(PROJECT_BUILD_DIR)/linux-$(DOWNLOAD_LINUX26_VERSION) $(LINUX26_DIR)
+ echo $(LINUX26_VERSION_PROBED) > $(PROJECT_BUILD_DIR)/.linux-version
endif
touch $@
@@ -400,6 +401,7 @@ endif
# -----------------------------------------------------------------------------
$(LINUX26_DIR)/.depend_done: $(LINUX26_DIR)/.configured $(LINUX26_MKIMAGE_DEP)
+ mkdir -p $(TARGET_DIR)/boot
-mv $(LINUX26_DIR)/localversion* $(TARGET_DIR)/boot
$(MAKE) $(LINUX26_MAKE_FLAGS) -C $(LINUX26_DIR) prepare
touch $@