summaryrefslogtreecommitdiff
path: root/target/linux
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-01-25 20:11:31 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-01-25 20:11:31 +0000
commit7e41b89b56c59928d7b2d65ba2d4601b32897561 (patch)
tree33672b22a4447575c0f0399f4e9faf0b768a634a /target/linux
parentd7cb72db645f0901ddeb51c7a559b2a25888e65a (diff)
target/linux-advanced: default to menuconfig for all archs
Default to menuconfig for atmel targets as well, mention QT3 dependency for make xconfig and update affected defconfigs.
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/Config.in.advanced5
-rw-r--r--target/linux/Makefile.in.advanced2
2 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/Config.in.advanced b/target/linux/Config.in.advanced
index 45cf0fc22..4bcfbb363 100644
--- a/target/linux/Config.in.advanced
+++ b/target/linux/Config.in.advanced
@@ -390,7 +390,7 @@ config BR2_PACKAGE_LINUX_USE_XCONFIG
bool "Run make ARCH=$(ARCH) [xconfig|menuconfig] before build"
depends on BR2_PACKAGE_LINUX
help
- Configure Linux by make xconfig
+ Configure Linux by make xconfig|menuconfig
endchoice
config BR2_PACKAGE_LINUX_KCONFIG
@@ -406,14 +406,13 @@ config BR2_PACKAGE_LINUX_KCONFIG
choice
prompt "Preferred config tool"
- default BR2_MAKE_XCONFIG if BR2_TARGET_ATMEL
default BR2_MAKE_MENUCONFIG
depends on BR2_PACKAGE_LINUX_USE_XCONFIG
help
Define the preferred tool to invoke if a configuration is invalid
config BR2_MAKE_XCONFIG
- bool "make xconfig"
+ bool "make xconfig (needs QT3 headers on host)"
help
Run "make xconfig" if kernel ".config" is invalid
diff --git a/target/linux/Makefile.in.advanced b/target/linux/Makefile.in.advanced
index 9a7f0fdf0..45fb4cb72 100644
--- a/target/linux/Makefile.in.advanced
+++ b/target/linux/Makefile.in.advanced
@@ -112,7 +112,7 @@ endif
KERNEL_CONFIG_METHOD:=$(strip $(subst ",,$(BR2_KERNEL_CONFIG_METHOD)))
#"))
ifeq ($(KERNEL_CONFIG_METHOD),)
-KERNEL_CONFIG_METHOD:=xconfig
+KERNEL_CONFIG_METHOD:=menuconfig
endif
# -----------------------------------------------------------------------------