summaryrefslogtreecommitdiff
path: root/target/linux
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-02-25 14:28:35 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-02-25 14:28:35 +0000
commitaae3f1b6b3447ea5f38bfc821d71a0853e7caa46 (patch)
tree903c48bb48a8534d8555fe6497465b51dbd875be /target/linux
parente95aedd05be8204ba3e7cd85eddf686024b8530c (diff)
linux: always apply platform patches if available
Get rid of BR2_KERNEL_HEADERS_PATCH_DIR config, and simply always apply platform patches if available.
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/Makefile.in2
-rw-r--r--target/linux/Makefile.in.advanced6
2 files changed, 3 insertions, 5 deletions
diff --git a/target/linux/Makefile.in b/target/linux/Makefile.in
index 494de7f30..ff0b88e34 100644
--- a/target/linux/Makefile.in
+++ b/target/linux/Makefile.in
@@ -129,7 +129,7 @@ $(LINUX26_DIR)/.patched: $(LINUX26_DIR)/.unpacked $(LINUX_HEADERS_DEPENDS)
ifeq ($(BR2_KERNEL_HEADERS_RT),y)
toolchain/patch-kernel.sh $(LINUX26_DIR) $(DL_DIR) $(LINUX_RT_SOURCE)
endif
-ifeq ($(BR2_KERNEL_HEADERS_PATCH_DIR),y)
+ifneq ($(KERNEL_HEADERS_PATCH_DIR),)
toolchain/patch-kernel.sh $(LINUX26_DIR) $(KERNEL_HEADERS_PATCH_DIR) \
linux-$(LINUX26_VERSION)-\*.patch{,.gz,.bz2}
endif
diff --git a/target/linux/Makefile.in.advanced b/target/linux/Makefile.in.advanced
index 122358410..614346c89 100644
--- a/target/linux/Makefile.in.advanced
+++ b/target/linux/Makefile.in.advanced
@@ -263,11 +263,9 @@ endif
ifeq ($(BR2_KERNEL_HEADERS_RT),y)
toolchain/patch-kernel.sh $(LINUX26_DIR) $(DL_DIR) $(LINUX_RT_SOURCE)
endif
-ifeq ($(BR2_KERNEL_HEADERS_PATCH_DIR),y)
- if [ -d $(KERNEL_HEADERS_PATCH_DIR) ] ; then \
+ifneq ($(KERNEL_HEADERS_PATCH_DIR),)
toolchain/patch-kernel.sh $(LINUX26_DIR) $(KERNEL_HEADERS_PATCH_DIR) \
- linux-$(LINUX26_VERSION)\*.patch{,.gz,.bz2} ; \
- fi
+ linux-$(LINUX26_VERSION)\*.patch{,.gz,.bz2}
endif
ifeq ($(BR2_PACKAGE_OPENSWAN),y)
toolchain/patch-kernel.sh $(LINUX26_DIR) package/openswan \