summaryrefslogtreecommitdiff
path: root/target/squashfs/squashfsroot.mk
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-21 14:32:38 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-21 14:32:38 +0000
commit1afb8226cbaf011f81158b63c2c169ce05842d21 (patch)
treee98b0ceb30d7dc264513db121b16dab45282c9a3 /target/squashfs/squashfsroot.mk
parent3cca2a310d5e6a793784c9c5c28076f161713077 (diff)
- start to use BR2_HAVE_MANPAGES and BR2_HAVE_INFOPAGES
- always error out if ldconfig for the target fails (was inconsistent..)
Diffstat (limited to 'target/squashfs/squashfsroot.mk')
-rw-r--r--target/squashfs/squashfsroot.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index 8e6166e77..3fbdf9a4f 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -45,8 +45,12 @@ SQUASHFS_TARGET:=$(IMAGE).squashfs
squashfsroot: host-fakeroot makedevs squashfs
-@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
+ifneq ($(BR2_HAVE_MANPAGES),y)
@rm -rf $(TARGET_DIR)/usr/man
+endif
+ifneq ($(BR2_HAVE_INFOPAGES),y)
@rm -rf $(TARGET_DIR)/usr/info
+endif
$(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null
# Use fakeroot to pretend all target binaries are owned by root
rm -f $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(SQUASHFS_TARGET))