summaryrefslogtreecommitdiff
path: root/target/squashfs
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-04-10 22:49:48 +0000
committerEric Andersen <andersen@codepoet.org>2006-04-10 22:49:48 +0000
commit674d61d84b2b754057be95038462b97ad83f759f (patch)
tree08f19974441080147b1a2406bbe62b5847035162 /target/squashfs
parentbfcb34c69f8a1e28bbd2daf3d5841350fa855f10 (diff)
yet again... rework fakeroot handling to ensure fakeroot is invoked just once,
as it seems to sometimes lose values logged during from earlier invocations.
Diffstat (limited to 'target/squashfs')
-rw-r--r--target/squashfs/squashfsroot.mk24
1 files changed, 9 insertions, 15 deletions
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index baed90289..e8ba54394 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -64,23 +64,17 @@ squashfsroot: host-fakeroot makedevs squashfs
rm -f $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET)
touch $(STAGING_DIR)/.fakeroot.00000
cat $(STAGING_DIR)/.fakeroot* > $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET)
- -$(STAGING_DIR)/usr/bin/fakeroot \
- -i $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET) \
- -s $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET) -- \
- chown -R root:root $(TARGET_DIR)
+ echo "chown -R root:root $(TARGET_DIR)" >> $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET)
# Use fakeroot to pretend to create all needed device nodes
- $(STAGING_DIR)/usr/bin/fakeroot \
- -i $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET) \
- -s $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET) -- \
- $(STAGING_DIR)/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)
+ echo "$(STAGING_DIR)/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
+ >> $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET)
# Use fakeroot so mksquashfs believes the previous fakery
- $(STAGING_DIR)/usr/bin/fakeroot \
- -i $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET) \
- -s $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET) -- \
- $(SQUASHFS_DIR)/squashfs-tools/mksquashfs \
- $(TARGET_DIR) \
- $(SQUASHFS_TARGET) \
- -noappend $(SQUASHFS_ENDIANNESS)
+ echo "$(SQUASHFS_DIR)/squashfs-tools/mksquashfs " \
+ "$(TARGET_DIR) $(SQUASHFS_TARGET) " \
+ "-noappend $(SQUASHFS_ENDIANNESS)" \
+ >> $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET)
+ chmod a+x $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET)
+ $(STAGING_DIR)/usr/bin/fakeroot -- $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET)
-@rm -f $(STAGING_DIR)/_fakeroot.$(notdir $SQUASHFS_TARGET)
squashfsroot-source: squashfs-source