summaryrefslogtreecommitdiff
path: root/target/tar
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-15 16:49:39 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-02-15 16:49:39 +0000
commit0091f181efdb042e778a357df0ba8ffaddfc9b0c (patch)
tree12579ad566f77af82be219c517dc9b23738058f0 /target/tar
parent2f67d9e2fe7bbec10e67bf7e52999c594c4d6400 (diff)
- do not use TARGET_DEVICE_TABLE if is is empty
Diffstat (limited to 'target/tar')
-rw-r--r--target/tar/tarroot.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/tar/tarroot.mk b/target/tar/tarroot.mk
index 943cc171b..19aff6109 100644
--- a/target/tar/tarroot.mk
+++ b/target/tar/tarroot.mk
@@ -32,9 +32,11 @@ tarroot: host-fakeroot makedevs
touch $(STAGING_DIR)/.fakeroot.00000
cat $(STAGING_DIR)/.fakeroot* > $(STAGING_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
echo "chown -R root:root $(TARGET_DIR)" >> $(STAGING_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
+ifneq ($(TARGET_DEVICE_TABLE),)
# Use fakeroot to pretend to create all needed device nodes
echo "$(STAGING_DIR)/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
>> $(STAGING_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
+endif
# Use fakeroot so tar believes the previous fakery
echo "tar -c$(TAR_OPTS)f $(TAR_TARGET) -C $(TARGET_DIR) ." \
>> $(STAGING_DIR)/_fakeroot.$(notdir $(TAR_TARGET))