summaryrefslogtreecommitdiff
path: root/target/tar
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-08-08 06:57:43 +0000
committerEric Andersen <andersen@codepoet.org>2005-08-08 06:57:43 +0000
commit06c5ff4e823cab16987d89c585ef2de4a3db2a7b (patch)
tree7c112f6202f48b15e550f602a0e750c7205eb421 /target/tar
parentab3bf08f9c3009364da713bbda03902b9cc06d3b (diff)
minor cleanup for target handling
Diffstat (limited to 'target/tar')
-rw-r--r--target/tar/tarroot.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/target/tar/tarroot.mk b/target/tar/tarroot.mk
index 526f156b6..1d2d6a6ca 100644
--- a/target/tar/tarroot.mk
+++ b/target/tar/tarroot.mk
@@ -10,11 +10,9 @@ tarroot: host-fakeroot makedevs
-@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/info
- test -e "$(TARGET_DIR)/etc/ld.so.conf" \
- && /sbin/ldconfig -r $(TARGET_DIR) \
- || true
+ -/sbin/ldconfig -r $(TARGET_DIR) 2>/dev/null
# Use fakeroot to pretend all target binaries are owned by root
- $(STAGING_DIR)/usr/bin/fakeroot \
+ -$(STAGING_DIR)/usr/bin/fakeroot \
-i $(STAGING_DIR)/fakeroot.env \
-s $(STAGING_DIR)/fakeroot.env -- \
chown -R root:root $(TARGET_DIR)