summaryrefslogtreecommitdiff
path: root/target/tar
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-09 16:06:06 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-09 16:06:06 +0000
commitcd0a84da7e04e09353e04e1d0500641db6500e21 (patch)
tree29a7ee866b750e872b98ed184414ce270783fdc2 /target/tar
parent80e5aaa56b6985890d09a23228e0cbf55d298356 (diff)
allow users to generate tarballs of the target filesystem
Diffstat (limited to 'target/tar')
-rw-r--r--target/tar/Config.in14
-rw-r--r--target/tar/Makefile.in3
-rw-r--r--target/tar/tarroot.mk25
3 files changed, 42 insertions, 0 deletions
diff --git a/target/tar/Config.in b/target/tar/Config.in
new file mode 100644
index 000000000..8cce50770
--- /dev/null
+++ b/target/tar/Config.in
@@ -0,0 +1,14 @@
+menuconfig BR2_TARGET_ROOTFS_TAR
+ bool "tar the root filesystem for the target device"
+ default n
+ help
+ Build a tar archive of the root filesystem
+
+config BR2_TARGET_ROOTFS_TAR_OPTIONS
+ string "random options to pass to tar"
+ depends on BR2_TARGET_ROOTFS_TAR
+ default ""
+ help
+ Common options:
+ j - compress with bzip2
+ z - compress with gzip
diff --git a/target/tar/Makefile.in b/target/tar/Makefile.in
new file mode 100644
index 000000000..d5f130899
--- /dev/null
+++ b/target/tar/Makefile.in
@@ -0,0 +1,3 @@
+ifeq ($(strip $(BR2_TARGET_ROOTFS_TAR)),y)
+TARGETS+=tarroot
+endif
diff --git a/target/tar/tarroot.mk b/target/tar/tarroot.mk
new file mode 100644
index 000000000..a7627bf40
--- /dev/null
+++ b/target/tar/tarroot.mk
@@ -0,0 +1,25 @@
+#############################################################
+#
+# tar to archive target filesystem
+#
+#############################################################
+
+TAR_OPTS := $(strip $(BR2_TARGET_ROOTFS_TAR_OPTIONS))
+
+TAR_TARGET := $(IMAGE).tar
+
+$(TAR_TARGET):
+ -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
+ @rm -rf $(TARGET_DIR)/usr/man
+ @rm -rf $(TARGET_DIR)/usr/share/man
+ @rm -rf $(TARGET_DIR)/usr/info
+ tar -c$(TAR_OPTS)f $(TAR_TARGET) -C $(TARGET_DIR) .
+
+tarroot: $(TAR_TARGET)
+ @ls -l $(TAR_TARGET)
+
+tarroot-source:
+
+tarroot-clean:
+
+tarroot-dirclean: